kernel: add more SCTP related configuration symbols
[openwrt/svn-archive/archive.git] / package / kernel / modules / video.mk
index d1e2be3c65417b3aa9bb18e906431ef835845108..e652e8a4f0e89b1b30a8665eb26d1ddb2d7ec897 100644 (file)
@@ -8,12 +8,84 @@
 
 VIDEO_MENU:=Video Support
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
+V4L2_DIR=v4l2-core
+V4L2_USB_DIR=usb
+else
+V4L2_DIR=video
+V4L2_USB_DIR=video
+endif
+
+
+define KernelPackage/fb
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer support
+  DEPENDS:=@DISPLAY_SUPPORT
+  KCONFIG:=CONFIG_FB
+  FILES:=$(LINUX_DIR)/drivers/video/fb.ko
+  AUTOLOAD:=$(call AutoLoad,06,fb)
+endef
+
+define KernelPackage/fb/description
+  Kernel support for framebuffers
+endef
+
+$(eval $(call KernelPackage,fb))
+
+define KernelPackage/fb-cfb-fillrect
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer software rectangle filling support
+  DEPENDS:=+kmod-fb
+  KCONFIG:=CONFIG_FB_CFB_FILLRECT
+  FILES:=$(LINUX_DIR)/drivers/video/cfbfillrect.ko
+  AUTOLOAD:=$(call AutoLoad,07,cfbfillrect)
+endef
+
+define KernelPackage/fb-cfb-fillrect/description
+  Kernel support for software rectangle filling
+endef
+
+$(eval $(call KernelPackage,fb-cfb-fillrect))
+
+
+define KernelPackage/fb-cfb-copyarea
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer software copy area support
+  DEPENDS:=+kmod-fb
+  KCONFIG:=CONFIG_FB_CFB_COPYAREA
+  FILES:=$(LINUX_DIR)/drivers/video/cfbcopyarea.ko
+  AUTOLOAD:=$(call AutoLoad,07,cfbcopyarea)
+endef
+
+define KernelPackage/fb-cfb-copyarea/description
+  Kernel support for software copy area
+endef
+
+$(eval $(call KernelPackage,fb-cfb-copyarea))
+
+define KernelPackage/fb-cfb-imgblt
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer software image blit support
+  DEPENDS:=+kmod-fb
+  KCONFIG:=CONFIG_FB_CFB_IMAGEBLIT
+  FILES:=$(LINUX_DIR)/drivers/video/cfbimgblt.ko
+  AUTOLOAD:=$(call AutoLoad,07,cfbimgblt)
+endef
+
+define KernelPackage/fb-cfb-imgblt/description
+  Kernel support for software image blitting
+endef
+
+$(eval $(call KernelPackage,fb-cfb-imgblt))
+
+
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
   TITLE=Video4Linux support
-  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT +!TARGET_etrax:kmod-i2c-core
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
   KCONFIG:= \
        CONFIG_MEDIA_SUPPORT=m \
+       CONFIG_MEDIA_CAMERA_SUPPORT=y \
        CONFIG_VIDEO_DEV \
        CONFIG_VIDEO_V4L1=y \
        CONFIG_VIDEO_ALLOW_V4L1=y \
@@ -23,8 +95,8 @@ define KernelPackage/video-core
        CONFIG_V4L_PLATFORM_DRIVERS=y \
        CONFIG_V4L_ISA_PARPORT_DRIVERS=y
   FILES:= \
-       $(LINUX_DIR)/drivers/media/video/v4l2-common.ko \
-       $(LINUX_DIR)/drivers/media/video/videodev.ko
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/v4l2-common.ko \
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videodev.ko
   AUTOLOAD:=$(call AutoLoad,60, videodev v4l2-common)
 endef
 
@@ -40,6 +112,13 @@ define AddDepends/video
   DEPENDS+=kmod-video-core $(1)
 endef
 
+define AddDepends/camera
+  SUBMENU:=$(VIDEO_MENU)
+  KCONFIG+=CONFIG_MEDIA_USB_SUPPORT=y \
+        CONFIG_MEDIA_CAMERA_SUPPORT=y
+  DEPENDS+=kmod-video-core $(1)
+endef
+
 
 define KernelPackage/video-videobuf2
   TITLE:=videobuf2 lib
@@ -48,9 +127,9 @@ define KernelPackage/video-videobuf2
        CONFIG_VIDEOBUF2_MEMOPS \
        CONFIG_VIDEOBUF2_VMALLOC
   FILES:= \
-       $(LINUX_DIR)/drivers/media/video/videobuf2-core.ko \
-       $(LINUX_DIR)/drivers/media/video/videobuf2-memops.ko \
-       $(LINUX_DIR)/drivers/media/video/videobuf2-vmalloc.ko
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-core.ko \
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-memops.ko \
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-vmalloc.ko
   AUTOLOAD:=$(call AutoLoad,65,videobuf2-core videobuf2-memops videobuf2-vmalloc)
   $(call AddDepends/video)
 endef
@@ -66,9 +145,9 @@ define KernelPackage/video-cpia2
   TITLE:=CPIA2 video driver
   DEPENDS:=@USB_SUPPORT +kmod-usb-core
   KCONFIG:=CONFIG_VIDEO_CPIA2
-  FILES:=$(LINUX_DIR)/drivers/media/video/cpia2/cpia2.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/cpia2/cpia2.ko
   AUTOLOAD:=$(call AutoLoad,70,cpia2)
-  $(call AddDepends/video)
+  $(call AddDepends/camera)
 endef
 
 define KernelPackage/video-cpia2/description
@@ -82,9 +161,9 @@ define KernelPackage/video-sn9c102
   TITLE:=SN9C102 Camera Chip support
   DEPENDS:=@USB_SUPPORT +kmod-usb-core
   KCONFIG:=CONFIG_USB_SN9C102
-  FILES:=$(LINUX_DIR)/drivers/media/video/sn9c102/sn9c102.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/sn9c102/sn9c102.ko
   AUTOLOAD:=$(call AutoLoad,70,gspca_sn9c20x)
-  $(call AddDepends/video)
+  $(call AddDepends/camera)
 endef
 
 
@@ -98,13 +177,13 @@ $(eval $(call KernelPackage,video-sn9c102))
 
 define KernelPackage/video-pwc
   TITLE:=Philips USB webcam support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +!LINUX_2_6_39:kmod-video-videobuf2
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
   KCONFIG:= \
        CONFIG_USB_PWC \
        CONFIG_USB_PWC_DEBUG=n
-  FILES:=$(LINUX_DIR)/drivers/media/video/pwc/pwc.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/pwc/pwc.ko
   AUTOLOAD:=$(call AutoLoad,70,pwc)
-  $(call AddDepends/video)
+  $(call AddDepends/camera)
 endef
 
 
@@ -118,9 +197,9 @@ define KernelPackage/video-uvc
   TITLE:=USB Video Class (UVC) support
   DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
   KCONFIG:= CONFIG_USB_VIDEO_CLASS
-  FILES:=$(LINUX_DIR)/drivers/media/video/uvc/uvcvideo.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/uvc/uvcvideo.ko
   AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
-  $(call AddDepends/video)
+  $(call AddDepends/camera)
   $(call AddDepends/input)
 endef
 
@@ -135,11 +214,11 @@ $(eval $(call KernelPackage,video-uvc))
 define KernelPackage/video-gspca-core
   MENU:=1
   TITLE:=GSPCA webcam core support framework
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-input-core
   KCONFIG:=CONFIG_USB_GSPCA
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_main.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_main.ko
   AUTOLOAD:=$(call AutoLoad,70,gspca_main)
-  $(call AddDepends/video)
+  $(call AddDepends/camera)
 endef
 
 define KernelPackage/video-gspca-core/description
@@ -150,7 +229,7 @@ endef
 $(eval $(call KernelPackage,video-gspca-core))
 
 
-define AddDepends/video-gspca
+define AddDepends/camera-gspca
   SUBMENU:=$(VIDEO_MENU)
   DEPENDS+=kmod-video-gspca-core $(1)
 endef
@@ -159,9 +238,9 @@ endef
 define KernelPackage/video-gspca-conex
   TITLE:=conex webcam support
   KCONFIG:=CONFIG_USB_GSPCA_CONEX
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_conex.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_conex.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_conex)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-conex/description
@@ -174,9 +253,9 @@ $(eval $(call KernelPackage,video-gspca-conex))
 define KernelPackage/video-gspca-etoms
   TITLE:=etoms webcam support
   KCONFIG:=CONFIG_USB_GSPCA_ETOMS
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_etoms.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_etoms.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_etoms)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-etoms/description
@@ -189,9 +268,9 @@ $(eval $(call KernelPackage,video-gspca-etoms))
 define KernelPackage/video-gspca-finepix
   TITLE:=finepix webcam support
   KCONFIG:=CONFIG_USB_GSPCA_FINEPIX
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_finepix.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_finepix.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_finepix)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-finepix/description
@@ -204,9 +283,9 @@ $(eval $(call KernelPackage,video-gspca-finepix))
 define KernelPackage/video-gspca-mars
   TITLE:=mars webcam support
   KCONFIG:=CONFIG_USB_GSPCA_MARS
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_mars.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_mars.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_mars)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-mars/description
@@ -219,9 +298,9 @@ $(eval $(call KernelPackage,video-gspca-mars))
 define KernelPackage/video-gspca-mr97310a
   TITLE:=mr97310a webcam support
   KCONFIG:=CONFIG_USB_GSPCA_MR97310A
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_mr97310a.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_mr97310a.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_mr97310a)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-mr97310a/description
@@ -234,9 +313,9 @@ $(eval $(call KernelPackage,video-gspca-mr97310a))
 define KernelPackage/video-gspca-ov519
   TITLE:=ov519 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_OV519
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_ov519.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_ov519.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_ov519)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-ov519/description
@@ -249,9 +328,9 @@ $(eval $(call KernelPackage,video-gspca-ov519))
 define KernelPackage/video-gspca-ov534
   TITLE:=ov534 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_OV534
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_ov534.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_ov534.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_ov534)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-ov534/description
@@ -264,9 +343,9 @@ $(eval $(call KernelPackage,video-gspca-ov534))
 define KernelPackage/video-gspca-ov534-9
   TITLE:=ov534-9 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_OV534_9
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_ov534_9.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_ov534_9.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_ov534_9)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-ov534-9/description
@@ -279,9 +358,9 @@ $(eval $(call KernelPackage,video-gspca-ov534-9))
 define KernelPackage/video-gspca-pac207
   TITLE:=pac207 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_PAC207
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_pac207.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_pac207.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_pac207)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-pac207/description
@@ -294,9 +373,9 @@ $(eval $(call KernelPackage,video-gspca-pac207))
 define KernelPackage/video-gspca-pac7311
   TITLE:=pac7311 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_PAC7311
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_pac7311.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_pac7311.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_pac7311)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-pac7311/description
@@ -309,9 +388,9 @@ $(eval $(call KernelPackage,video-gspca-pac7311))
 define KernelPackage/video-gspca-se401
   TITLE:=se401 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SE401
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_se401.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_se401.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_se401)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-se401/description
@@ -324,9 +403,9 @@ $(eval $(call KernelPackage,video-gspca-se401))
 define KernelPackage/video-gspca-sn9c20x
   TITLE:=sn9c20x webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SN9C20X
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sn9c20x.ko
-  AUTOLOAD:=$(call AutoLoad,75,sn9c20x)
-  $(call AddDepends/video-gspca)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sn9c20x.ko
+  AUTOLOAD:=$(call AutoLoad,75,gspca_sn9c20x)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sn9c20x/description
@@ -339,9 +418,9 @@ $(eval $(call KernelPackage,video-gspca-sn9c20x))
 define KernelPackage/video-gspca-sonixb
   TITLE:=sonixb webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SONIXB
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sonixb.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sonixb.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sonixb)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sonixb/description
@@ -354,9 +433,9 @@ $(eval $(call KernelPackage,video-gspca-sonixb))
 define KernelPackage/video-gspca-sonixj
   TITLE:=sonixj webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SONIXJ
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sonixj.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sonixj.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sonixj)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sonixj/description
@@ -369,9 +448,9 @@ $(eval $(call KernelPackage,video-gspca-sonixj))
 define KernelPackage/video-gspca-spca500
   TITLE:=spca500 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA500
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca500.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca500.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca500)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca500/description
@@ -384,9 +463,9 @@ $(eval $(call KernelPackage,video-gspca-spca500))
 define KernelPackage/video-gspca-spca501
   TITLE:=spca501 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA501
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca501.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca501.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca501)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca501/description
@@ -399,9 +478,9 @@ $(eval $(call KernelPackage,video-gspca-spca501))
 define KernelPackage/video-gspca-spca505
   TITLE:=spca505 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA505
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca505.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca505.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca505)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca505/description
@@ -414,9 +493,9 @@ $(eval $(call KernelPackage,video-gspca-spca505))
 define KernelPackage/video-gspca-spca506
   TITLE:=spca506 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA506
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca506.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca506.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca506)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca506/description
@@ -429,9 +508,9 @@ $(eval $(call KernelPackage,video-gspca-spca506))
 define KernelPackage/video-gspca-spca508
   TITLE:=spca508 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA508
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca508.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca508.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca508)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca508/description
@@ -444,9 +523,9 @@ $(eval $(call KernelPackage,video-gspca-spca508))
 define KernelPackage/video-gspca-spca561
   TITLE:=spca561 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA561
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca561.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca561.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca561)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca561/description
@@ -459,9 +538,9 @@ $(eval $(call KernelPackage,video-gspca-spca561))
 define KernelPackage/video-gspca-sq905
   TITLE:=sq905 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SQ905
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sq905.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sq905.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sq905)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sq905/description
@@ -474,9 +553,9 @@ $(eval $(call KernelPackage,video-gspca-sq905))
 define KernelPackage/video-gspca-sq905c
   TITLE:=sq905c webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SQ905C
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sq905c.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sq905c.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sq905c)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sq905c/description
@@ -489,9 +568,9 @@ $(eval $(call KernelPackage,video-gspca-sq905c))
 define KernelPackage/video-gspca-stk014
   TITLE:=stk014 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_STK014
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_stk014.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_stk014.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_stk014)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-stk014/description
@@ -504,9 +583,9 @@ $(eval $(call KernelPackage,video-gspca-stk014))
 define KernelPackage/video-gspca-sunplus
   TITLE:=sunplus webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SUNPLUS
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sunplus.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sunplus.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sunplus)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sunplus/description
@@ -519,9 +598,9 @@ $(eval $(call KernelPackage,video-gspca-sunplus))
 define KernelPackage/video-gspca-t613
   TITLE:=t613 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_T613
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_t613.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_t613.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_t613)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-t613/description
@@ -534,9 +613,9 @@ $(eval $(call KernelPackage,video-gspca-t613))
 define KernelPackage/video-gspca-tv8532
   TITLE:=tv8532 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_TV8532
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_tv8532.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_tv8532.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_tv8532)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-tv8532/description
@@ -549,9 +628,9 @@ $(eval $(call KernelPackage,video-gspca-tv8532))
 define KernelPackage/video-gspca-vc032x
   TITLE:=vc032x webcam support
   KCONFIG:=CONFIG_USB_GSPCA_VC032X
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_vc032x.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_vc032x.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_vc032x)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-vc032x/description
@@ -564,9 +643,9 @@ $(eval $(call KernelPackage,video-gspca-vc032x))
 define KernelPackage/video-gspca-zc3xx
   TITLE:=zc3xx webcam support
   KCONFIG:=CONFIG_USB_GSPCA_ZC3XX
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_zc3xx.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_zc3xx.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_zc3xx)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-zc3xx/description
@@ -579,9 +658,9 @@ $(eval $(call KernelPackage,video-gspca-zc3xx))
 define KernelPackage/video-gspca-m5602
   TITLE:=m5602 webcam support
   KCONFIG:=CONFIG_USB_M5602
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/m5602/gspca_m5602.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/m5602/gspca_m5602.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_m5602)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-m5602/description
@@ -594,9 +673,9 @@ $(eval $(call KernelPackage,video-gspca-m5602))
 define KernelPackage/video-gspca-stv06xx
   TITLE:=stv06xx webcam support
   KCONFIG:=CONFIG_USB_STV06XX
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/stv06xx/gspca_stv06xx.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/stv06xx/gspca_stv06xx.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_stv06xx)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-stv06xx/description
@@ -609,9 +688,9 @@ $(eval $(call KernelPackage,video-gspca-stv06xx))
 define KernelPackage/video-gspca-gl860
   TITLE:=gl860 webcam support
   KCONFIG:=CONFIG_USB_GL860
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gl860/gspca_gl860.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gl860/gspca_gl860.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_gl860)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-gl800/description
@@ -624,9 +703,9 @@ $(eval $(call KernelPackage,video-gspca-gl860))
 define KernelPackage/video-gspca-jeilinj
   TITLE:=jeilinj webcam support
   KCONFIG:=CONFIG_USB_GSPCA_JEILINJ
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_jeilinj.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_jeilinj.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_jeilinj)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-jeilinj/description
@@ -639,9 +718,9 @@ $(eval $(call KernelPackage,video-gspca-jeilinj))
 define KernelPackage/video-gspca-konica
   TITLE:=konica webcam support
   KCONFIG:=CONFIG_USB_GSPCA_KONICA
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_konica.ko
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_konica.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_konica)
-  $(call AddDepends/video-gspca)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-konica/description