fix kmod-hostap build on 2.4, add kmod-hostap-cs (closes: #1957)
[openwrt/svn-archive/archive.git] / package / kernel / modules / wireless.mk
index a9ec1f5de8e49e81445085578798d1fb313e796e..6887a491a37a3f4945b3c1b6728a37992a39c193 100644 (file)
@@ -8,10 +8,12 @@
 
 WIRELESS_MENU:=Wireless Drivers
 
+# NOTE: dependency on 2.6 was removed since it was inherited by kmod-hostap 
+#       and prevented it from even showing up in menuconfig on 2.4
 define KernelPackage/ieee80211
   SUBMENU:=$(WIRELESS_MENU)
   TITLE:=802.11 Networking stack
-  DEPENDS:=@LINUX_2_6 +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic
+  DEPENDS:=+kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic
   KCONFIG:= \
        CONFIG_IEEE80211 \
        CONFIG_IEEE80211_CRYPT_WEP \