kexec-tools: Update package to version 2.0.1
[openwrt/svn-archive/archive.git] / package / kexec-tools / Makefile
index 602b33c29eb3f23bfa914c54d06589f9dcc84823..53c75b75a61519b5e57062318de3c76e078b9b19 100644 (file)
@@ -1,27 +1,26 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kexec-tools
-PKG_VERSION:=testing-20080324
+PKG_VERSION:=2.0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
-PKG_MD5SUM:=9f442520b0e238ae5beb4ebea0867377
+PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/horms/kexec-tools
+PKG_MD5SUM:=67c1a396fdf67b984dad939a59a01571
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/kexec-tools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@i386||@powerpc||@mipsel +zlib
+  DEPENDS:=@armeb||@i386||@powerpc64||@mipsel||@mips +zlib
   TITLE:=Kernel boots kernel
   URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
   MENU:=1
@@ -36,9 +35,11 @@ define Package/kexec-tools/config
        source "$(SOURCE)/kexec-config.in"
 endef
 
+KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
+
 CONFIGURE_ARGS = \
-               --target=$(CONFIG_KEXEC_TOOLS_TARGET_NAME)-linux-uclibc \
-               --host=$(GNU_TARGET_NAME)-uclibc \
+               --target=$(KEXEC_TARGET_NAME) \
+               --host=$(REAL_GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \
                --program-prefix="" \
                --program-suffix="" \
@@ -49,7 +50,9 @@ CONFIGURE_ARGS = \
                --libexecdir=/usr/lib \
                --sysconfdir=/etc \
 
-CONFIGURE_VARS += BUILD_CC=$(HOSTCC)
+CONFIGURE_VARS += \
+       BUILD_CC="$(HOSTCC)" \
+       TARGET_CC="$(TARGET_CC)" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) all