Added identification of WRT610N and its button/led definitions.
[openwrt/svn-archive/archive.git] / package / kexec-tools / Makefile
index c4b1379466d05e6912967374267f719a306c5bc5..c7e52903897f0ceed305fdd2599cf1ce5e04d022 100644 (file)
@@ -50,21 +50,30 @@ CONFIGURE_ARGS = \
                --bindir=/usr/bin \
                --sbindir=/usr/sbin \
                --libexecdir=/usr/lib \
-               --sysconfdir=/etc \
+               --sysconfdir=/etc
 
 CONFIGURE_VARS += \
        BUILD_CC="$(HOSTCC)" \
-       TARGET_CC="$(TARGET_CC)" \
+       TARGET_CC="$(TARGET_CC)"
+
+kexec-extra-sbin-$(CONFIG_KEXEC_TOOLS_kdump) += kdump
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Package/kexec-tools/install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(1)" \
-               install
-       rm -rf $(1)/usr/man
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) \
+               $(addprefix $(PKG_INSTALL_DIR)/usr/sbin/, \
+                       $(kexec-extra-sbin-y)) \
+               $(kexec-extra-bin-y) \
+               $(PKG_INSTALL_DIR)/usr/sbin/kexec \
+               $(1)/usr/sbin
+
+# make a link for compatability with other distros
+       $(INSTALL_DIR) $(1)/sbin
+       ln -s /usr/sbin/kexec $(1)/sbin/kexec
 endef
 
 $(eval $(call BuildPackage,kexec-tools))