[package] add mips64 support to kexec-tools, counterpart of r17768.
[openwrt/svn-archive/archive.git] / package / kexec-tools / Makefile
index 7ee1c2cd5b2c11ba7e0929b8945c5e8bda644f4b..d350bb2c8b6157a3b5c8106a7752beb9b9cc811d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kexec-tools
 PKG_VERSION:=2.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/horms/kexec-tools
@@ -71,6 +71,9 @@ define Package/kexec-tools/install
                $(PKG_INSTALL_DIR)/usr/sbin/kexec \
                $(1)/usr/sbin
 
+# make a link for compatability with other distros
+       $(INSTALL_DIR) $(1)/sbin
+       ln -s /usr/sbin/kexec $(1)/sbin/kexec
 endef
 
 $(eval $(call BuildPackage,kexec-tools))