[package] add mips64 support to kexec-tools, counterpart of r17768.
[openwrt/svn-archive/archive.git] / package / kexec-tools / Makefile
index de0ad37fb7b906a1153a3b96ab809806b1843af1..d350bb2c8b6157a3b5c8106a7752beb9b9cc811d 100644 (file)
@@ -1,52 +1,79 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kexec-tools
-PKG_VERSION:=1.101
-PKG_RELEASE:=1
+PKG_VERSION:=2.0.1
+PKG_RELEASE:=3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/horms/kexec-tools
+PKG_MD5SUM:=67c1a396fdf67b984dad939a59a01571
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.xmission.com/~ebiederm/files/kexec/
-PKG_MD5SUM:=b4f7ffcc294d41a6a4c40d6e44b7734d
-PKG_CAT:=zcat
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/kexec-tools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6_X86 +zlib
+  DEPENDS:=@armeb||@i386||@powerpc64||@mipsel||@mips +zlib
   TITLE:=Kernel boots kernel
-  DESCRIPTION:=\
-       kexec is a set of systems call that allows you to load \\\
-       another kernel from the currently executing Linux kernel.
-  URL:=http://www.xmission.com/~ebiederm/files/kexec/README
+  URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
+  MENU:=1
+endef
+
+define Package/kexec-tools/description
+ kexec is a set of systems call that allows you to load
+ another kernel from the currently executing Linux kernel.
+endef
+
+define Package/kexec-tools/config
+       source "$(SOURCE)/kexec-config.in"
 endef
 
-MAKE_FLAGS += \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
-       BUILD_CFLAGS="-O2" \
-       LIBS="$(TARGET_LDFLAGS) -lz" \
-       install
+KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
+
+CONFIGURE_ARGS = \
+               --target=$(KEXEC_TARGET_NAME) \
+               --host=$(REAL_GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --program-prefix="" \
+               --program-suffix="" \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc
+
+CONFIGURE_VARS += \
+       BUILD_CC="$(HOSTCC)" \
+       TARGET_CC="$(TARGET_CC)"
+
+kexec-extra-sbin-$(CONFIG_KEXEC_TOOLS_kdump) += kdump
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(call Build/Compile/Default,)
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Package/kexec-tools/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kexec $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kdump $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) \
+               $(addprefix $(PKG_INSTALL_DIR)/usr/sbin/, \
+                       $(kexec-extra-sbin-y)) \
+               $(kexec-extra-bin-y) \
+               $(PKG_INSTALL_DIR)/usr/sbin/kexec \
+               $(1)/usr/sbin
+
+# make a link for compatability with other distros
+       $(INSTALL_DIR) $(1)/sbin
+       ln -s /usr/sbin/kexec $(1)/sbin/kexec
 endef
 
 $(eval $(call BuildPackage,kexec-tools))