replace cflags hacks with the correct solution
[openwrt/svn-archive/archive.git] / package / keynote / Makefile
index 61eae5857577c20be36d62f893bd2f7d7b1da93d..5b27257b4a74ddb3831210a5fea861f381f3d3af 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keynote
 PKG_VERSION:=2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
@@ -41,15 +41,10 @@ MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)"
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include/keynote
-       $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(STAGING_DIR)/usr/include/keynote/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/keynote \
-               $(STAGING_DIR)/usr/lib/libkeynote.a
+       mkdir -p $(1)/usr/include/keynote
+       $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(1)/usr/include/keynote/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libkeynote.a $(1)/usr/lib/
 endef
 
 define Package/keynote/install