Toto, we don't support Linux 2.4 anymore..
[openwrt/svn-archive/archive.git] / package / libnl / Makefile
index 6802ed16f8a6eb454fa3731c02c40f835b4a720f..eb9831a21e1430bcf412dfe7e1368912ee804b92 100644 (file)
@@ -37,18 +37,16 @@ define Build/Compile
                install
 endef
 
-ifneq ($(CONFIG_LINUX_2_6),)
-  define Build/InstallDev
+define Build/InstallDev
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
        mkdir -p $(1)/usr/include/libnl
        $(CP) $(PKG_BUILD_DIR)/include/linux $(1)/usr/include/libnl/
-  endef
+endef
 
-  define Package/libnl/install
+define Package/libnl/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.* $(1)/usr/lib/
-  endef
-endif
+endef
 
 $(eval $(call BuildPackage,libnl))