[package] libreadline: install *.so symlinks as well (#4872)
[openwrt/svn-archive/archive.git] / package / libreadline / Makefile
index 750b691c1f8f9fe4543795f918bafd05a884c7cc..90219e55b66b485914172562b3c2fd28564b4f0b 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
 
 include $(TOPDIR)/rules.mk
 
 
 include $(TOPDIR)/rules.mk
 
@@ -53,15 +52,15 @@ define Build/Compile
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so.5,so.5.2} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so,so.5,so.5.2} $(1)/usr/lib/
 endef
 
 define Package/libreadline/install
        $(INSTALL_DIR) $(1)/usr/lib
 endef
 
 define Package/libreadline/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so.5,so.5.2} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so,so.5,so.5.2} $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libreadline))
 endef
 
 $(eval $(call BuildPackage,libreadline))