[package] iwinfo: iwinfo_hardware_id_from_mtd() never writes, so do not request write...
[openwrt/svn-archive/archive.git] / package / librpc / Makefile
index 558bfc9e3664c662012346fcf9ba267b9615e07b..5a469211643c9a2cb5107964ff7d6adef0c7f326 100644 (file)
@@ -2,14 +2,25 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=librpc
 PKG_VERSION:=0.9.32-rc2
-PKG_RELEASE:=1
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/uclibc-rpc.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=49f63f433ddd1fb7ad1e450094b82aacaa3b0a7d
+PKG_SOURCE_VERSION:=0a2179bbc0844928f2a0ec01dba93d9b5d6d41a7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-CMAKE_INSTALL:=1
+
+ifndef CONFIG_NATIVE_TOOLCHAIN
+ ifndef CONFIG_EXTERNAL_TOOLCHAIN
+  ifdef CONFIG_USE_UCLIBC
+    BUILD_LIBRPC=1
+  endif
+ endif
+endif
+
+ifdef BUILD_LIBRPC
+  CMAKE_INSTALL:=1
+endif
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
@@ -18,12 +29,30 @@ define Package/librpc
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=uClibc RPC library
-  DEPENDS:=@USE_UCLIBC
+  MDEPENDS:=@USE_UCLIBC
 endef
 
-define Package/librpc/install
+ifdef BUILD_LIBRPC
+  define Package/librpc/install
        $(INSTALL_DIR) $(1)/lib/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/librpc.so $(1)/lib/
-endef
+  endef
+else
+  define Build/Prepare
+  endef
+
+  define Build/Configure
+  endef
+
+  define Build/Compile
+  endef
+
+  define Build/Install
+  endef
+
+  define Package/librpc/install
+       true
+  endef
+endif
 
 $(eval $(call BuildPackage,librpc))