[package] iwinfo: iwinfo_hardware_id_from_mtd() never writes, so do not request write...
[openwrt/svn-archive/archive.git] / package / librpc / Makefile
index 5dc6162763270513dd2d0844f1a2c4ac4611bbfc..5a469211643c9a2cb5107964ff7d6adef0c7f326 100644 (file)
@@ -7,9 +7,18 @@ PKG_RELEASE=$(PKG_SOURCE_VERSION)
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/uclibc-rpc.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=49f63f433ddd1fb7ad1e450094b82aacaa3b0a7d
+PKG_SOURCE_VERSION:=0a2179bbc0844928f2a0ec01dba93d9b5d6d41a7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-ifdef CONFIG_USE_UCLIBC
+
+ifndef CONFIG_NATIVE_TOOLCHAIN
+ ifndef CONFIG_EXTERNAL_TOOLCHAIN
+  ifdef CONFIG_USE_UCLIBC
+    BUILD_LIBRPC=1
+  endif
+ endif
+endif
+
+ifdef BUILD_LIBRPC
   CMAKE_INSTALL:=1
 endif
 
@@ -20,14 +29,30 @@ define Package/librpc
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=uClibc RPC library
-  DEPENDS:=@USE_UCLIBC
+  MDEPENDS:=@USE_UCLIBC
 endef
 
-ifdef CONFIG_USE_UCLIBC
+ifdef BUILD_LIBRPC
   define Package/librpc/install
        $(INSTALL_DIR) $(1)/lib/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/librpc.so $(1)/lib/
   endef
+else
+  define Build/Prepare
+  endef
+
+  define Build/Configure
+  endef
+
+  define Build/Compile
+  endef
+
+  define Build/Install
+  endef
+
+  define Package/librpc/install
+       true
+  endef
 endif
 
 $(eval $(call BuildPackage,librpc))