ustream-ssl: update to the latest version, adds support for the current cyassl versio...
[openwrt/svn-archive/archive.git] / package / libs / ustream-ssl / Makefile
index 9fef5e7..d61c4e8 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ustream-ssl
-PKG_VERSION:=2013-01-22
+PKG_VERSION:=2013-10-30
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/ustream-ssl.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=da607e6272d789ed5dae3b0efff90912fda6f81f
+PKG_SOURCE_VERSION:=1dc753d6438121ef4cc57b185ea340c082d362c6
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -31,21 +31,31 @@ endef
 define Package/libustream-openssl
   $(Package/libustream/default)
   TITLE += (openssl)
-  DEPENDS += +PACKAGE_libustream-openssl:libopenssl
+  DEPENDS += +libopenssl
   VARIANT:=openssl
 endef
 
 define Package/libustream-cyassl
   $(Package/libustream/default)
   TITLE += (cyassl)
-  DEPENDS += +PACKAGE_libustream-cyassl:libcyassl
+  DEPENDS += +libcyassl
   VARIANT:=cyassl
 endef
 
+define Package/libustream-polarssl
+  $(Package/libustream/default)
+  TITLE += (polarssl)
+  DEPENDS += +libpolarssl
+  VARIANT:=polarssl
+endef
+
 ifeq ($(BUILD_VARIANT),cyassl)
   TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/cyassl
   CMAKE_OPTIONS += -DCYASSL=on
 endif
+ifeq ($(BUILD_VARIANT),polarssl)
+  CMAKE_OPTIONS += -DPOLARSSL=on
+endif
 
 define Package/libustream/default/install
        $(INSTALL_DIR) $(1)/lib/
@@ -54,6 +64,8 @@ endef
 
 Package/libustream-openssl/install = $(Package/libustream/default/install)
 Package/libustream-cyassl/install = $(Package/libustream/default/install)
+Package/libustream-polarssl/install = $(Package/libustream/default/install)
 
+$(eval $(call BuildPackage,libustream-polarssl))
 $(eval $(call BuildPackage,libustream-cyassl))
 $(eval $(call BuildPackage,libustream-openssl))