[package] libtool: don't install aclocal directory again if symlink into $(STAGING_DI...
[openwrt/svn-archive/archive.git] / package / libtool / Makefile
index 5b30d5007c2a95fdd202699a94ea3f46be7ba219..4986f5614eb673fe823951d7c80468ec2254fb89 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtool
-PKG_VERSION:=1.5.26
+PKG_VERSION:=2.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/libtool
-PKG_MD5SUM:=aa9c5107f3ec9ef4200eb6556f3b3c29
+PKG_MD5SUM:=b32b04148ecdd7344abc6fe8bd1bb021
 
 HOST_PATCH_DIR=/dev/null
 
@@ -48,6 +48,8 @@ define Build/InstallDev
        $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(2)/bin/libtool
        $(CP) $(2)/bin/libtool $(2)/bin/libtool-ucxx
        $(SED) 's,-lstdc++,-luClibc++,g' $(2)/bin/libtool-ucxx
+       [ -h $(STAGING_DIR)/host/share/aclocal ] && \
+               rm -rf $(TMP_DIR)/stage-$(PKG_NAME)/host/share/aclocal || true
 endef
 
 define Package/libltdl/install