upgrade to new version of br2684ctl
[openwrt/svn-archive/archive.git] / package / linux-atm / Makefile
index 9aae0a0b0ed1a4f0b59aedaf1ca5b3811156affe..4edd362710821916e35191a0ddabd213de005b42 100644 (file)
@@ -15,10 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/linux-atm/
 PKG_MD5SUM:=84fef49cc39ff2605204246666f65864
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -35,27 +31,18 @@ define Package/linux-atm
        This package contains a library for accessing the Linux ATM subsystem.
 endef
 
-define Package/br2684ctl
-  $(call Package/linux-atm/Default)
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+linux-atm
-  TITLE:=RFC2684 bridging utility
-  DESCRIPTION:=\
-       This package contains an ATM RFC2684 bridging utility.
-endef
-
 define Build/Configure
        $(call Build/Configure/Default)
        # prevent autoheader invocation
        touch $(PKG_BUILD_DIR)/stamp-h.in
 endef
 
+TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/src/include $(TARGET_CFLAGS)
 define Build/Compile
-       $(call Build/Compile/Default, \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
+               all install
 endef
 
 define Build/InstallDev
@@ -77,15 +64,7 @@ define Package/linux-atm/install
        cp -f $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(1)/usr/lib
 endef
 
-define Package/br2684ctl/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/net
-       $(INSTALL_DATA) ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
-endef
-
 $(eval $(call BuildPackage,linux-atm))
-$(eval $(call BuildPackage,br2684ctl))
 
 $(eval $(call RequireCommand,automake, \
        $(PKG_NAME) requires automake. \