pass the CFLAGS through the environment on compile and fix a few packages
[openwrt/svn-archive/archive.git] / package / linux-atm / Makefile
index 3745c7c87e63c34158d8500f17b856954882e962..7691c1149a14da5f7c2ef86d4af46efa96fe4628 100644 (file)
@@ -51,11 +51,12 @@ define Build/Configure
        touch $(PKG_BUILD_DIR)/stamp-h.in
 endef
 
+TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/src/include $(TARGET_CFLAGS)
 define Build/Compile
-       $(call Build/Compile/Default, \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
+               all install
 endef
 
 define Build/InstallDev
@@ -73,20 +74,20 @@ define Build/UninstallDev
 endef
 
 define Package/linux-atm/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        cp -f $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(1)/usr/lib
 endef
 
 define Package/br2684ctl/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/hotplug.d/net
-       install -m0644 ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/net
+       $(INSTALL_DATA) ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
 endef
 
 $(eval $(call BuildPackage,linux-atm))
 $(eval $(call BuildPackage,br2684ctl))
 
-$(eval $(call RequireCommand,automake-1.4, \
-       $(PKG_NAME) requires automake-1.4. \
+$(eval $(call RequireCommand,automake, \
+       $(PKG_NAME) requires automake. \
 ))