package/linux-atm: refresh patches
[openwrt/svn-archive/archive.git] / package / linux-atm / patches / 200-no_libfl.patch
index 1f7ae028c5a0c1b2d6c7432fdcfbb6b4fd2a8afd..4a95c9ae2d1739f1fd371681453cb92ff9033a09 100644 (file)
@@ -1,66 +1,38 @@
-Index: linux-atm-2.4.1/src/qgen/Makefile.am
-===================================================================
---- linux-atm-2.4.1.orig/src/qgen/Makefile.am  2007-10-20 19:19:10.354218533 +0200
-+++ linux-atm-2.4.1/src/qgen/Makefile.am       2007-10-20 19:19:16.814586679 +0200
-@@ -3,7 +3,7 @@
+--- a/src/qgen/Makefile.am
++++ b/src/qgen/Makefile.am
+@@ -2,7 +2,7 @@ noinst_PROGRAMS = qgen
  
  qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
                qgen.h second.c third.c
 -qgen_LDADD = -lfl
 +qgen_LDADD = 
  
- q_dump_SOURCES = common.c
- q_dump_LDADD = qd.dump.standalone.o
-Index: linux-atm-2.4.1/src/qgen/Makefile.in
-===================================================================
---- linux-atm-2.4.1.orig/src/qgen/Makefile.in  2007-10-20 19:19:11.898306522 +0200
-+++ linux-atm-2.4.1/src/qgen/Makefile.in       2007-10-20 19:19:16.814586679 +0200
-@@ -90,7 +90,7 @@
- qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c           qgen.h second.c third.c
+ CC = @CC_FOR_BUILD@
+ CFLAGS = @CFLAGS_FOR_BUILD@
+--- a/src/qgen/Makefile.in
++++ b/src/qgen/Makefile.in
+@@ -58,7 +58,7 @@ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+ am__mv = mv -f
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+-      $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
++      $(AM_CFLAGS) $(CFLAGS)
+ LTCOMPILE = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+       --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+       $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+@@ -208,7 +208,7 @@ top_srcdir = @top_srcdir@
+ qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
+               qgen.h second.c third.c
  
 -qgen_LDADD = -lfl
 +qgen_LDADD = 
  
- q_dump_SOURCES = common.c
- q_dump_LDADD = qd.dump.standalone.o
-Index: linux-atm-2.4.1/src/qgen/ql_l.c
-===================================================================
---- linux-atm-2.4.1.orig/src/qgen/ql_l.c       2007-10-20 19:19:11.906306980 +0200
-+++ linux-atm-2.4.1/src/qgen/ql_l.c    2007-10-20 19:19:16.842588278 +0200
-@@ -501,6 +501,11 @@
- #include "qgen.h"
- #include "ql_y.h"
-+int yywrap(void)
-+{
-+        return 1;
-+}
-+
- typedef struct _tree {
-     struct _tree *left,*right;
-Index: linux-atm-2.4.1/src/sigd/cfg_l.c
-===================================================================
---- linux-atm-2.4.1.orig/src/sigd/cfg_l.c      2007-10-20 19:19:10.378219897 +0200
-+++ linux-atm-2.4.1/src/sigd/cfg_l.c   2007-10-20 19:19:16.854588969 +0200
-@@ -11,6 +11,10 @@
- #include <stdio.h>
- #include <unistd.h>
-+int yywrap(void)
-+{
-+        return 1;
-+}
- /* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
- #ifdef c_plusplus
-Index: linux-atm-2.4.1/src/sigd/Makefile.am
-===================================================================
---- linux-atm-2.4.1.orig/src/sigd/Makefile.am  2007-10-20 19:19:10.386220355 +0200
-+++ linux-atm-2.4.1/src/sigd/Makefile.am       2007-10-20 19:19:16.882590565 +0200
-@@ -8,7 +8,7 @@
-                       $(top_builddir)/src/qgen/qd.dump.o \
+ #TESTS = $(check_PROGRAMS)
+ EXTRA_DIST = ql_y.h ql_y.c ql_l.c
+--- a/src/sigd/Makefile.am
++++ b/src/sigd/Makefile.am
+@@ -8,7 +8,7 @@ atmsigd_XTRAS = mess.o $(top_builddir)/s
+                       $(top_builddir)/src/q2931/qd.dump.o \
                        $(top_builddir)/src/lib/libatm.la \
                        $(top_builddir)/src/saal/libsaal.a
 -atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
@@ -68,23 +40,19 @@ Index: linux-atm-2.4.1/src/sigd/Makefile.am
  atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
  
  CLEANFILES = mess.c
-Index: linux-atm-2.4.1/src/sigd/Makefile.in
-===================================================================
---- linux-atm-2.4.1.orig/src/sigd/Makefile.in  2007-10-20 19:19:12.018313361 +0200
-+++ linux-atm-2.4.1/src/sigd/Makefile.in       2007-10-20 19:19:16.886590795 +0200
-@@ -92,7 +92,7 @@
- atmsigd_XTRAS = mess.o $(top_builddir)/src/qgen/q.out.o                       $(top_builddir)/src/qgen/qd.dump.o                      $(top_builddir)/src/lib/libatm.la                       $(top_builddir)/src/saal/libsaal.a
+--- a/src/sigd/Makefile.in
++++ b/src/sigd/Makefile.in
+@@ -244,7 +244,7 @@ atmsigd_XTRAS = mess.o $(top_builddir)/s
+                       $(top_builddir)/src/lib/libatm.la \
+                       $(top_builddir)/src/saal/libsaal.a
  
 -atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
 +atmsigd_LDADD = $(atmsigd_XTRAS) 
  atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
  CLEANFILES = mess.c
-Index: linux-atm-2.4.1/src/switch/debug/debug.c
-===================================================================
---- linux-atm-2.4.1.orig/src/switch/debug/debug.c      2007-10-20 19:19:12.414335932 +0200
-+++ linux-atm-2.4.1/src/switch/debug/debug.c   2007-10-20 19:19:16.894591246 +0200
+ sysconf_DATA = atmsigd.conf
+--- a/src/switch/debug/debug.c
++++ b/src/switch/debug/debug.c
 @@ -20,6 +20,11 @@
  
  #define PRV(call) ((FAB *) (call)->fab)
@@ -97,11 +65,9 @@ Index: linux-atm-2.4.1/src/switch/debug/debug.c
  
  typedef struct _fab {
      CALL *next; /* relay.c may not keep track of calls, but WE are */
-Index: linux-atm-2.4.1/src/switch/debug/Makefile.am
-===================================================================
---- linux-atm-2.4.1.orig/src/switch/debug/Makefile.am  2007-10-20 19:19:10.406221495 +0200
-+++ linux-atm-2.4.1/src/switch/debug/Makefile.am       2007-10-20 19:19:16.906591931 +0200
-@@ -5,7 +5,7 @@
+--- a/src/switch/debug/Makefile.am
++++ b/src/switch/debug/Makefile.am
+@@ -5,7 +5,7 @@ INCLUDES = -I$(srcdir)/../../q2931
  sw_debug_SOURCES = debug.c
  sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
                        $(top_builddir)/src/lib/libatm.la
@@ -110,24 +76,21 @@ Index: linux-atm-2.4.1/src/switch/debug/Makefile.am
                        
  sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
  
-Index: linux-atm-2.4.1/src/switch/debug/Makefile.in
-===================================================================
---- linux-atm-2.4.1.orig/src/switch/debug/Makefile.in  2007-10-20 19:19:12.378333877 +0200
-+++ linux-atm-2.4.1/src/switch/debug/Makefile.in       2007-10-20 19:19:16.918592613 +0200
-@@ -92,7 +92,7 @@
- sw_debug_SOURCES = debug.c
- sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a                   $(top_builddir)/src/lib/libatm.la
+--- a/src/switch/debug/Makefile.in
++++ b/src/switch/debug/Makefile.in
+@@ -199,7 +199,8 @@ sw_debug_SOURCES = debug.c
+ sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
+                       $(top_builddir)/src/lib/libatm.la
  
 -sw_debug_LDADD = $(sw_debug_XTRAS) -lfl
-+sw_debug_LDADD = $(sw_debug_XTRAS) 
++sw_debug_LDADD = $(sw_debug_XTRAS)
++
  sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
-Index: linux-atm-2.4.1/src/switch/tcp/Makefile.am
-===================================================================
---- linux-atm-2.4.1.orig/src/switch/tcp/Makefile.am    2007-10-20 19:19:10.422222406 +0200
-+++ linux-atm-2.4.1/src/switch/tcp/Makefile.am 2007-10-20 19:19:16.922592837 +0200
-@@ -5,7 +5,7 @@
+ EXTRA_DIST = demo README
+ all: all-am
+--- a/src/switch/tcp/Makefile.am
++++ b/src/switch/tcp/Makefile.am
+@@ -5,7 +5,7 @@ INCLUDES = -I$(srcdir)/../../q2931
  sw_tcp_SOURCES = tcpsw.c
  sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
                $(top_builddir)/src/lib/libatm.la
@@ -136,23 +99,19 @@ Index: linux-atm-2.4.1/src/switch/tcp/Makefile.am
  sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
  
  EXTRA_DIST = mkfiles README
-Index: linux-atm-2.4.1/src/switch/tcp/Makefile.in
-===================================================================
---- linux-atm-2.4.1.orig/src/switch/tcp/Makefile.in    2007-10-20 19:19:12.422336385 +0200
-+++ linux-atm-2.4.1/src/switch/tcp/Makefile.in 2007-10-20 19:19:16.926593064 +0200
-@@ -92,7 +92,7 @@
- sw_tcp_SOURCES = tcpsw.c
- sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a             $(top_builddir)/src/lib/libatm.la
+--- a/src/switch/tcp/Makefile.in
++++ b/src/switch/tcp/Makefile.in
+@@ -199,7 +199,7 @@ sw_tcp_SOURCES = tcpsw.c
+ sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
+               $(top_builddir)/src/lib/libatm.la
  
 -sw_tcp_LDADD = $(sw_tcp_XTRAS) -lfl
 +sw_tcp_LDADD = $(sw_tcp_XTRAS) 
  sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
  EXTRA_DIST = mkfiles README
-Index: linux-atm-2.4.1/src/switch/tcp/tcpsw.c
-===================================================================
---- linux-atm-2.4.1.orig/src/switch/tcp/tcpsw.c        2007-10-20 19:19:12.426336614 +0200
-+++ linux-atm-2.4.1/src/switch/tcp/tcpsw.c     2007-10-20 19:19:16.954594660 +0200
+ all: all-am
+--- a/src/switch/tcp/tcpsw.c
++++ b/src/switch/tcp/tcpsw.c
 @@ -35,6 +35,10 @@
  #define MAX_PACKET (ATM_MAX_AAL5_PDU+sizeof(struct atmtcp_hdr))
  #define BUFFER_SIZE (MAX_PACKET*2)
@@ -164,45 +123,66 @@ Index: linux-atm-2.4.1/src/switch/tcp/tcpsw.c
  
  typedef struct _table {
      struct _link *out;        /* output port */
-Index: linux-atm-2.4.1/src/test/ispl_l.c
-===================================================================
---- linux-atm-2.4.1.orig/src/test/ispl_l.c     2007-10-20 19:19:10.442223546 +0200
-+++ linux-atm-2.4.1/src/test/ispl_l.c  2007-10-20 19:19:16.962595124 +0200
-@@ -11,6 +11,11 @@
- #include <stdio.h>
- #include <unistd.h>
-+int yywrap(void)
-+{
-+      return 1;
-+}
-+
- /* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
- #ifdef c_plusplus
-Index: linux-atm-2.4.1/src/test/Makefile.am
-===================================================================
---- linux-atm-2.4.1.orig/src/test/Makefile.am  2007-10-20 19:19:11.858304242 +0200
-+++ linux-atm-2.4.1/src/test/Makefile.am       2007-10-20 19:19:16.962595124 +0200
-@@ -15,7 +15,7 @@
+--- a/src/test/Makefile.am
++++ b/src/test/Makefile.am
+@@ -20,7 +20,7 @@ br_SOURCES = br.c
  bw_SOURCES = bw.c
  isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
  isp_XTRAS = $(LDADD)
 -isp_LDADD = $(isp_XTRAS) -lfl
-+isp_LDADD = $(isp_XTRAS) 
- isp_DEPENDENCIES = $(isp_XTRAS) errnos.inc
++isp_LDADD = $(isp_XTRAS)
+ isp_DEPENDENCIES = $(isp_XTRAS)
  window_SOURCES = window.c
  
-Index: linux-atm-2.4.1/src/test/Makefile.in
-===================================================================
---- linux-atm-2.4.1.orig/src/test/Makefile.in  2007-10-20 19:19:11.826302420 +0200
-+++ linux-atm-2.4.1/src/test/Makefile.in       2007-10-20 19:19:16.962595124 +0200
-@@ -102,7 +102,7 @@
+--- a/src/test/Makefile.in
++++ b/src/test/Makefile.in
+@@ -282,7 +282,7 @@ br_SOURCES = br.c
  bw_SOURCES = bw.c
  isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
  isp_XTRAS = $(LDADD)
 -isp_LDADD = $(isp_XTRAS) -lfl
-+isp_LDADD = $(isp_XTRAS) 
- isp_DEPENDENCIES = $(isp_XTRAS) errnos.inc
++isp_LDADD = $(isp_XTRAS)
+ isp_DEPENDENCIES = $(isp_XTRAS)
  window_SOURCES = window.c
+ CLEANFILES = errnos.inc
+--- a/src/test/ispl_l.l
++++ b/src/test/ispl_l.l
+@@ -18,6 +18,11 @@
+ #include "ispl_y.h"
++int yywrap(void)
++{
++       return 1;
++}
++
+ static int lineno = 1;
+ %}
+--- a/src/qgen/ql_l.l
++++ b/src/qgen/ql_l.l
+@@ -11,6 +11,11 @@
+ #include "ql_y.h"
++int yywrap(void)
++{
++        return 1;
++}
++
+ typedef struct _tree {
+     struct _tree *left,*right;
+     const char str[0];
+--- a/src/sigd/cfg_l.l
++++ b/src/sigd/cfg_l.l
+@@ -16,6 +16,10 @@
+ #include "cfg_y.h"
++int yywrap(void)
++{
++        return 1;
++}
  
+ static int lineno = 1;
+ static int token; /* f@#%ing flex doesn't grok return after BEGIN */