[packages] claim maintainership for resolveip and lua
[openwrt/svn-archive/archive.git] / package / lua / Makefile
index 9d9c77b9e4fc1313e7f3cdb1bf09e75332214a00..53acdde9fdf9a7c404cba430334fe0b513f78ece 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lua
 PKG_VERSION:=5.1.4
-PKG_RELEASE:=5
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
@@ -29,6 +29,7 @@ define Package/lua/Default
   CATEGORY:=Languages
   TITLE:=Lua programming language
   URL:=http://www.lua.org/
+  MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 endef
 
 define Package/lua/Default/description
@@ -115,10 +116,15 @@ define Host/Configure
        $(SED) 's,"/usr/local/","$(STAGING_DIR_HOST)/",' $(HOST_BUILD_DIR)/src/luaconf.h
 endef
 
-LUA_OS.Darwin:=macosx
-LUA_OS.FreeBSD:=freebsd
-LUA_OS:=$(LUA_OS.$(HOST_OS))
-LUA_OS?=linux
+ifeq ($(HOST_OS),Darwin)
+       LUA_OS:=macosx
+else
+       ifeq ($(HOST_OS),FreeBSD)
+               LUA_OS:=freebsd
+       else
+               LUA_OS:=linux
+       endif
+endif
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) \