[package] lua: install lua.pc pkgconfig file as well (closes: #5132)
[openwrt/svn-archive/archive.git] / package / lua / Makefile
index eff31390affd213063cf05e1e0fdbbec5a7a6b52..c7e1814f92c3b388b567ac84814b4d376d2b7193 100644 (file)
@@ -1,10 +1,9 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -22,10 +21,10 @@ PKG_MD5SUM:=d0870f2de55d59c1c8419f36e8fac150
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lua/Default
-  SUBMENU:=LUA
+  SUBMENU:=Lua
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=LUA programming language
+  TITLE:=Lua programming language
   URL:=http://www.lua.org/
 endef
 
@@ -45,7 +44,7 @@ endef
 
 define Package/liblua/description
 $(call Package/lua/Default/description)
- This package contains the LUA shared libraries, needed by other programs.
+ This package contains the Lua shared libraries, needed by other programs.
 endef
 
 define Package/lua
@@ -56,7 +55,7 @@ endef
 
 define Package/lua/description
 $(call Package/lua/Default/description)
- This package contains the LUA language interpreter.
+ This package contains the Lua language interpreter.
 endef
 
 define Package/luac
@@ -67,7 +66,7 @@ endef
 
 define Package/luac/description
 $(call Package/lua/Default/description)
- This package contains the LUA language compiler.
+ This package contains the Lua language compiler.
 endef
 
 define Package/lua-examples
@@ -78,7 +77,7 @@ endef
 
 define Package/lua-examples/description
 $(call Package/lua/Default/description)
- This package contains LUA language examples.
+ This package contains Lua language examples.
 endef
 
 define Build/Configure
@@ -110,13 +109,15 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lua{,lib,conf}.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lauxlib.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lnum_config.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua.{a,so*} $(1)/usr/lib/
        ln -sf liblua.so.$(PKG_VERSION) $(1)/usr/lib/liblualib.so
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_BUILD_DIR)/etc/lua.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/liblua/install