[cosmetic] change occurences of LUA to Lua (from http://www.lua.org/about.html: Pleas...
[openwrt/svn-archive/archive.git] / package / lua / Makefile
index 0c2e8e24e907c28b8fd08acf3d7c6d62f89acab0..e60be8f4b9e7e42784f06df06b5116b73c30d0f8 100644 (file)
@@ -1,10 +1,9 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -19,14 +18,13 @@ PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
        http://www.tecgraf.puc-rio.br/lua/ftp/
 PKG_MD5SUM:=d0870f2de55d59c1c8419f36e8fac150
 
-include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lua/Default
-  SUBMENU:=LUA
+  SUBMENU:=Lua
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=LUA programming language
+  TITLE:=Lua programming language
   URL:=http://www.lua.org/
 endef
 
@@ -46,7 +44,7 @@ endef
 
 define Package/liblua/description
 $(call Package/lua/Default/description)
- This package contains the LUA shared libraries, needed by other programs.
+ This package contains the Lua shared libraries, needed by other programs.
 endef
 
 define Package/lua
@@ -57,7 +55,7 @@ endef
 
 define Package/lua/description
 $(call Package/lua/Default/description)
- This package contains the LUA language interpreter.
+ This package contains the Lua language interpreter.
 endef
 
 define Package/luac
@@ -68,7 +66,7 @@ endef
 
 define Package/luac/description
 $(call Package/lua/Default/description)
- This package contains the LUA language compiler.
+ This package contains the Lua language compiler.
 endef
 
 define Package/lua-examples
@@ -79,24 +77,12 @@ endef
 
 define Package/lua-examples/description
 $(call Package/lua/Default/description)
- This package contains LUA language examples.
+ This package contains Lua language examples.
 endef
 
-# Host build
-define Host/Configure
-
-endef
-
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)/src luac-host
+define Build/Configure
 endef
 
-define Host/Install
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/luac-host $(STAGING_DIR_HOST)/bin/luac
-endef
-
-# Target build
-
 TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC)
 
 ifneq ($(CONFIG_USE_EGLIBC),)
@@ -105,8 +91,6 @@ ifneq ($(CONFIG_USE_EGLIBC),)
   endif
 endif
 
-Build/Configure=$(Host/Configure)
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CROSS)gcc" \
@@ -155,7 +139,6 @@ define Package/lua-examples/install
                $(1)/usr/share/lua/examples/
 endef
 
-$(eval $(call HostBuild))
 $(eval $(call BuildPackage,liblua))
 $(eval $(call BuildPackage,lua))
 $(eval $(call BuildPackage,luac))