mac80211: cfg80211 should not depend on rfkill.
[openwrt/svn-archive/archive.git] / package / mac80211 / patches / 002-disable_rfkill.patch
index 6488ef6d1359cf2c17ec9c88f2e1ec6a8d01b760..7e4274f176ee302d98ca0ea4a0dbf9bef7092ec7 100644 (file)
@@ -1,58 +1,36 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -127,14 +127,14 @@ ifneq ($(CONFIG_PCI),)
+@@ -74,7 +74,7 @@ endif # build check
+ endif # kernel Makefile check
  
- CONFIG_ATH5K=m
- # CONFIG_ATH5K_DEBUG=y
--CONFIG_ATH5K_RFKILL=y
-+# CONFIG_ATH5K_RFKILL=y
- CONFIG_ATH9K=m
- # CONFIG_ATH9K_DEBUG=y
+ # These both are needed by compat-wireless || compat-bluetooth so enable them
+- CONFIG_COMPAT_RFKILL=y
++# CONFIG_COMPAT_RFKILL=y
  
- CONFIG_IWLWIFI=m
- CONFIG_IWLWIFI_LEDS=y
--CONFIG_IWLWIFI_RFKILL=y
-+# CONFIG_IWLWIFI_RFKILL=y
- CONFIG_IWLWIFI_SPECTRUM_MEASUREMENT=y
- # CONFIG_IWLWIFI_DEBUG=y
- # CONFIG_IWLWIFI_DEBUGFS=y
-@@ -154,7 +154,7 @@ CONFIG_B43_PCMCIA=y
- endif
- CONFIG_B43_PIO=y
- CONFIG_B43_LEDS=y
--CONFIG_B43_RFKILL=y
-+# CONFIG_B43_RFKILL=y
- CONFIG_B43_PHY_LP=y
- # CONFIG_B43_DEBUG=y
- # CONFIG_B43_FORCE_PIO=y
-@@ -164,7 +164,7 @@ CONFIG_B43LEGACY_HWRNG=y
- CONFIG_B43LEGACY_PCI_AUTOSELECT=y
- CONFIG_B43LEGACY_PCICORE_AUTOSELECT=y
- CONFIG_B43LEGACY_LEDS=y
--CONFIG_B43LEGACY_RFKILL=y
-+# CONFIG_B43LEGACY_RFKILL=y
- # CONFIG_B43LEGACY_DEBUG=y
- CONFIG_B43LEGACY_DMA=y
- CONFIG_B43LEGACY_PIO=y
-@@ -354,7 +354,7 @@ CONFIG_RT2X00_LIB=m
- CONFIG_RT2X00_LIB_HT=y
- CONFIG_RT2X00_LIB_FIRMWARE=y
- CONFIG_RT2X00_LIB_CRYPTO=y
--CONFIG_RT2X00_LIB_RFKILL=y
-+# CONFIG_RT2X00_LIB_RFKILL=y
- CONFIG_RT2X00_LIB_LEDS=y
- # CONFIG_RT2X00_LIB_DEBUGFS=y
- # CONFIG_RT2X00_DEBUG=y
-@@ -396,8 +396,8 @@ endif
+ ifeq ($(CONFIG_MAC80211),y)
+ $(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
+@@ -587,8 +587,8 @@ endif #CONFIG_COMPAT_KERNEL_27
  # We need the backported rfkill module on kernel < 2.6.31.
  # In more recent kernel versions use the in kernel rfkill module.
- ifdef CONFIG_COMPAT_WIRELESS_31
+ ifdef CONFIG_COMPAT_KERNEL_31
 -CONFIG_RFKILL_BACKPORT=m
 -CONFIG_RFKILL_BACKPORT_LEDS=y
 -CONFIG_RFKILL_BACKPORT_INPUT=y
 +# CONFIG_RFKILL_BACKPORT=m
 +# CONFIG_RFKILL_BACKPORT_LEDS=y
 +# CONFIG_RFKILL_BACKPORT_INPUT=y
- endif
+ endif #CONFIG_COMPAT_KERNEL_31
+--- a/include/linux/rfkill.h
++++ b/include/linux/rfkill.h
+@@ -3,6 +3,10 @@
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31))
++#undef CONFIG_RFKILL
++#undef CONFIG_RFKILL_LEDS
++#undef CONFIG_RFKILL_MODULE
++
+ #include_next <linux/rfkill.h>
  
+ #else