ath9k: fix endian issues on AR9003
[openwrt/svn-archive/archive.git] / package / mac80211 / patches / 002-disable_rfkill.patch
index c8183baae8546a97f9f468e3879ce38efb74ee33..d6b7cf23258c1f7c7c4514364e2fcb1ab661b5ba 100644 (file)
@@ -1,6 +1,6 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -72,7 +72,7 @@ endif # build check
+@@ -74,7 +74,7 @@ endif # build check
  endif # kernel Makefile check
  
  # These both are needed by compat-wireless || compat-bluetooth so enable them
@@ -9,7 +9,7 @@
  
  ifeq ($(CONFIG_MAC80211),y)
  $(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
-@@ -488,8 +488,8 @@ endif
+@@ -587,8 +587,8 @@ endif #CONFIG_COMPAT_KERNEL_27
  # We need the backported rfkill module on kernel < 2.6.31.
  # In more recent kernel versions use the in kernel rfkill module.
  ifdef CONFIG_COMPAT_KERNEL_31
@@ -19,5 +19,5 @@
 +# CONFIG_RFKILL_BACKPORT=m
 +# CONFIG_RFKILL_BACKPORT_LEDS=y
 +# CONFIG_RFKILL_BACKPORT_INPUT=y
- endif
+ endif #CONFIG_COMPAT_KERNEL_31