mac80211: update to latest version, fix tx gain patch
[openwrt/svn-archive/archive.git] / package / mac80211 / patches / 002-disable_rfkill.patch
index c5d1ccc507c18461bc24540a7fbd6f5c3bdc846f..f977c96059904949659ee00f83840647bbf5f8c2 100644 (file)
@@ -1,23 +1,38 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -72,7 +72,7 @@ endif # build check
+@@ -77,7 +77,7 @@ endif # build check
  endif # kernel Makefile check
  
  # These both are needed by compat-wireless || compat-bluetooth so enable them
-- CONFIG_COMPAT_RFKILL=y
-+# CONFIG_COMPAT_RFKILL=y
+- export CONFIG_COMPAT_RFKILL=y
++# export CONFIG_COMPAT_RFKILL=y
  
  ifeq ($(CONFIG_MAC80211),y)
  $(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
-@@ -495,8 +495,8 @@ endif
+@@ -688,10 +688,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
  # We need the backported rfkill module on kernel < 2.6.31.
  # In more recent kernel versions use the in kernel rfkill module.
- ifdef CONFIG_COMPAT_KERNEL_31
--CONFIG_RFKILL_BACKPORT=m
--CONFIG_RFKILL_BACKPORT_LEDS=y
--CONFIG_RFKILL_BACKPORT_INPUT=y
-+# CONFIG_RFKILL_BACKPORT=m
-+# CONFIG_RFKILL_BACKPORT_LEDS=y
-+# CONFIG_RFKILL_BACKPORT_INPUT=y
- endif
+ ifdef CONFIG_COMPAT_KERNEL_2_6_31
+-export CONFIG_RFKILL_BACKPORT=m
++#export CONFIG_RFKILL_BACKPORT=m
+ ifdef CONFIG_LEDS_TRIGGERS
+-export CONFIG_RFKILL_BACKPORT_LEDS=y
++#export CONFIG_RFKILL_BACKPORT_LEDS=y
+ endif #CONFIG_LEDS_TRIGGERS
+-export CONFIG_RFKILL_BACKPORT_INPUT=y
++#export CONFIG_RFKILL_BACKPORT_INPUT=y
+ endif #CONFIG_COMPAT_KERNEL_2_6_31
  
+--- a/include/linux/rfkill.h
++++ b/include/linux/rfkill.h
+@@ -3,6 +3,10 @@
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31))
++#undef CONFIG_RFKILL
++#undef CONFIG_RFKILL_LEDS
++#undef CONFIG_RFKILL_MODULE
++
+ #include_next <linux/rfkill.h>
+ #else