mac80211: update to wireless-testing 2010-11-30
[openwrt/svn-archive/archive.git] / package / mac80211 / patches / 008-led_default.patch
index a392e500ef0bcf217e84b3f8770a27ef7db1c011..af7633c594a8ed38f74cb541164488988cd9582d 100644 (file)
@@ -1,7 +1,7 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -115,7 +115,7 @@ CONFIG_COMPAT_MAC80211_RC_DEFAULT=minstr
CONFIG_MAC80211_RC_PID=y
+@@ -132,7 +132,7 @@ CONFIG_COMPAT_MAC80211_RC_DEFAULT=minstr
+ CONFIG_MAC80211_RC_PID=y
  CONFIG_MAC80211_RC_MINSTREL=y
  CONFIG_MAC80211_RC_MINSTREL_HT=y
 -CONFIG_MAC80211_LEDS=y
@@ -9,16 +9,16 @@
  
  # enable mesh networking too
  CONFIG_MAC80211_MESH=y
-@@ -218,7 +218,7 @@ CONFIG_B43_PCI_AUTOSELECT=y
- ifneq ($(CONFIG_PCMCIA),)
CONFIG_B43_PCMCIA=y
- endif
+@@ -240,7 +240,7 @@ CONFIG_B43_PCI_AUTOSELECT=y
+ ifdef CONFIG_PCMCIA
+ CONFIG_B43_PCMCIA=y
+ endif #CONFIG_PCMCIA
 -CONFIG_B43_LEDS=y
 +# CONFIG_B43_LEDS=y
  CONFIG_B43_PHY_LP=y
- # CONFIG_B43_NPHY is not set
+ CONFIG_B43_NPHY=y
  # CONFIG_B43_FORCE_PIO=y
-@@ -227,7 +227,7 @@ CONFIG_B43_PHY_LP=y
+@@ -249,7 +249,7 @@ CONFIG_B43_NPHY=y
  CONFIG_B43LEGACY=m
  CONFIG_B43LEGACY_HWRNG=y
  CONFIG_B43LEGACY_PCI_AUTOSELECT=y
@@ -27,7 +27,7 @@
  # CONFIG_B43LEGACY_DEBUG=y
  CONFIG_B43LEGACY_DMA=y
  CONFIG_B43LEGACY_PIO=y
-@@ -499,7 +499,7 @@ endif
+@@ -559,7 +559,7 @@ endif
  
  # p54
  CONFIG_P54_COMMON=m
  
  # Atheros
  CONFIG_ATH_COMMON=m
---- a/drivers/net/wireless/ath/ath9k/gpio.c
-+++ b/drivers/net/wireless/ath/ath9k/gpio.c
-@@ -54,6 +54,7 @@ static void ath_led_blink_work(struct wo
-               sc->sc_flags |= SC_OP_LED_ON;
- }
-+#ifdef CONFIG_LEDS_CLASS
- static void ath_led_brightness(struct led_classdev *led_cdev,
-                              enum led_brightness brightness)
- {
-@@ -90,10 +91,12 @@ static void ath_led_brightness(struct le
-               break;
-       }
- }
-+#endif
- static int ath_register_led(struct ath_softc *sc, struct ath_led *led,
-                           char *trigger)
- {
-+#ifdef CONFIG_LEDS_CLASS
-       int ret;
-       led->sc = sc;
-@@ -108,14 +111,19 @@ static int ath_register_led(struct ath_s
-       else
-               led->registered = 1;
-       return ret;
-+#else
-+      return 0;
-+#endif
- }
- static void ath_unregister_led(struct ath_led *led)
- {
-+#ifdef CONFIG_LEDS_CLASS
-       if (led->registered) {
-               led_classdev_unregister(&led->led_cdev);
-               led->registered = 0;
-       }
-+#endif
- }
- void ath_deinit_leds(struct ath_softc *sc)
 --- a/drivers/net/wireless/ath/ath9k/htc_drv_main.c
 +++ b/drivers/net/wireless/ath/ath9k/htc_drv_main.c
-@@ -872,6 +872,7 @@ static void ath9k_led_brightness_work(st
+@@ -863,6 +863,7 @@ static void ath9k_led_brightness_work(st
        }
  }
  
@@ -89,7 +46,7 @@
  static void ath9k_led_brightness(struct led_classdev *led_cdev,
                                 enum led_brightness brightness)
  {
-@@ -883,6 +884,7 @@ static void ath9k_led_brightness(struct 
+@@ -874,6 +875,7 @@ static void ath9k_led_brightness(struct 
                ieee80211_queue_delayed_work(priv->hw,
                                             &led->brightness_work, 0);
  }
@@ -97,7 +54,7 @@
  
  static void ath9k_led_stop_brightness(struct ath9k_htc_priv *priv)
  {
-@@ -895,6 +897,7 @@ static void ath9k_led_stop_brightness(st
+@@ -886,6 +888,7 @@ static void ath9k_led_stop_brightness(st
  static int ath9k_register_led(struct ath9k_htc_priv *priv, struct ath_led *led,
                              char *trigger)
  {
        int ret;
  
        led->priv = priv;
-@@ -912,14 +915,19 @@ static int ath9k_register_led(struct ath
+@@ -903,14 +906,19 @@ static int ath9k_register_led(struct ath
        INIT_DELAYED_WORK(&led->brightness_work, ath9k_led_brightness_work);
  
        return ret;