mac80211: update to latest version, fix tx gain patch
[openwrt/svn-archive/archive.git] / package / mac80211 / patches / 009-remove_mac80211_module_dependence.patch
index 6c421b0..e442c5e 100644 (file)
@@ -1,26 +1,11 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -42,23 +42,6 @@ $(error "ERROR: Your 2.6.27 kernel has C
+@@ -53,7 +53,7 @@ endif
+ ifeq ($(KERNEL_VERSION),2)
+ ifeq ($(shell test $(KERNEL_VERSION) -eq 2 -a $(KERNEL_26SUBLEVEL) -ge 27 -a $(KERNEL_26SUBLEVEL) -le 31 && echo yes),yes)
+ ifeq ($(CONFIG_MAC80211),)
+-$(error "ERROR: Your >=2.6.27 and <= 2.6.31 kernel has CONFIG_MAC80211 disabled, you should have it CONFIG_MAC80211=m if you want to use this thing.")
++# $(error "ERROR: Your >=2.6.27 and <= 2.6.31 kernel has CONFIG_MAC80211 disabled, you should have it CONFIG_MAC80211=m if you want to use this thing.")
+ endif
  endif
  endif
--# This is because with CONFIG_MAC80211 include/linux/skbuff.h will
--# enable on 2.6.27 a new attribute:
--#
--# skb->do_not_encrypt
--#
--# and on 2.6.28 another new attribute:
--#
--# skb->requeue
--#
--# In kernel 2.6.32 both attributes were removed.
--#
--ifeq ($(shell test $(KERNEL_SUBLEVEL) -ge 27 -a $(KERNEL_SUBLEVEL) -le 31 && echo yes),yes)
--ifeq ($(CONFIG_MAC80211),)
--$(error "ERROR: Your >=2.6.27 and <= 2.6.31 kernel has CONFIG_MAC80211 disabled, you should have it CONFIG_MAC80211=m if you want to use this thing.")
--endif
--endif
--
- ifneq ($(KERNELRELEASE),) # This prevents a warning
- ifeq ($(CONFIG_NET_SCHED),)