lantiq: allow platforms with rt2x00 to override the mac address without overriding...
[openwrt/svn-archive/archive.git] / package / mac80211 / patches / 010-no_pcmcia.patch
index 51189fc821815ae7a1fc9d0df0f322aafde8a14b..07a7abbe17f31963f1ff8584635515f1a4f7d29f 100644 (file)
@@ -1,20 +1,20 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -8,7 +8,7 @@ ifeq ($(wildcard $(KLIB_BUILD)/.config),
+@@ -2,7 +2,7 @@ ifeq ($(wildcard $(KLIB_BUILD)/.config),
  # These will be ignored by compat autoconf
-  CONFIG_PCI=y
-  CONFIG_USB=y
-- CONFIG_PCMCIA=y
-+# CONFIG_PCMCIA=y
+  export CONFIG_PCI=y
+  export CONFIG_USB=y
+- export CONFIG_PCMCIA=y
++# export CONFIG_PCMCIA=y
+ # export CONFIG_SSB=m
  else
  include $(KLIB_BUILD)/.config
- endif
-@@ -223,7 +223,7 @@ CONFIG_B43=m
- CONFIG_B43_HWRNG=y
- CONFIG_B43_PCI_AUTOSELECT=y
+@@ -289,7 +289,7 @@ export CONFIG_B43=m
+ export CONFIG_B43_HWRNG=y
+ export CONFIG_B43_PCI_AUTOSELECT=y
  ifdef CONFIG_PCMCIA
--CONFIG_B43_PCMCIA=y
-+# CONFIG_B43_PCMCIA=y
+-export CONFIG_B43_PCMCIA=y
++# export CONFIG_B43_PCMCIA=y
  endif #CONFIG_PCMCIA
- # CONFIG_B43_LEDS=y
CONFIG_B43_PHY_LP=y
+ ifdef CONFIG_MAC80211_LEDS
export CONFIG_B43_LEDS=y