mac80211: update to wireless-testing 2011-11-01
[openwrt/svn-archive/archive.git] / package / mac80211 / patches / 110-disable_usb_compat.patch
index d87eb47d406542e9c962dd1632286839d125ff17..7318cf935db11a680e3221455e5dc7a8302199ac 100644 (file)
@@ -1,6 +1,6 @@
 --- a/compat/compat-2.6.28.c
 +++ b/compat/compat-2.6.28.c
-@@ -166,7 +166,7 @@ EXPORT_SYMBOL(pcmcia_loop_config);
+@@ -165,7 +165,7 @@ EXPORT_SYMBOL(pcmcia_loop_config);
  
  #endif /* CONFIG_PCMCIA */
  
@@ -11,7 +11,7 @@
  {
 --- a/compat/compat-2.6.29.c
 +++ b/compat/compat-2.6.29.c
-@@ -53,7 +53,7 @@ void netdev_attach_ops(struct net_device
+@@ -49,7 +49,7 @@ void netdev_attach_ops(struct net_device
  EXPORT_SYMBOL(netdev_attach_ops);
  
  #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23))
  #if 0
  extern void usb_poison_urb(struct urb *urb);
  #endif
+--- a/config.mk
++++ b/config.mk
+@@ -453,7 +453,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
+ # This activates a threading fix for usb urb.
+ # this is mainline commit: b3e670443b7fb8a2d29831b62b44a039c283e351
+ # This fix will be included in some stable releases.
+-CONFIG_COMPAT_USB_URB_THREAD_FIX=y
++# CONFIG_COMPAT_USB_URB_THREAD_FIX=y
+ CONFIG_ATH9K_HTC=m
+ # CONFIG_ATH9K_HTC_DEBUGFS=y