mac80211: b43: Expose PIO mode fallback
[openwrt/svn-archive/archive.git] / package / mac80211 / patches / 810-b43_no_pio.patch
index 2aa426e37a21cbca9be654d358d5e581e04b34f4..037b8a37607f39384e1561cf033d7dfcb55122fa 100644 (file)
@@ -1,21 +1,21 @@
 --- a/drivers/net/wireless/b43/Makefile
 +++ b/drivers/net/wireless/b43/Makefile
-@@ -12,7 +12,7 @@ b43-y                                += xmit.o
+@@ -14,7 +14,7 @@ b43-y                                += xmit.o
  b43-y                         += lo.o
  b43-y                         += wa.o
  b43-y                         += dma.o
 -b43-y                         += pio.o
-+# b43-y                               += pio.o
++b43-$(CONFIG_B43_PIO)         += pio.o
  b43-y                         += rfkill.o
  b43-$(CONFIG_B43_LEDS)                += leds.o
  b43-$(CONFIG_B43_PCMCIA)      += pcmcia.o
 --- a/drivers/net/wireless/b43/main.c
 +++ b/drivers/net/wireless/b43/main.c
-@@ -1810,9 +1810,11 @@ static void b43_do_interrupt_thread(stru
+@@ -1812,9 +1812,11 @@ static void b43_do_interrupt_thread(stru
                               dma_reason[4], dma_reason[5]);
                        b43err(dev->wl, "This device does not support DMA "
                               "on your system. It will now be switched to PIO.\n");
-+#if 0
++#ifdef CONFIG_B43_PIO
                        /* Fall back to PIO transfers if we get fatal DMA errors! */
                        dev->use_pio = 1;
                        b43_controller_restart(dev, "DMA error");
                if (merged_dma_reason & B43_DMAIRQ_NONFATALMASK) {
 --- a/drivers/net/wireless/b43/pio.h
 +++ b/drivers/net/wireless/b43/pio.h
-@@ -151,15 +151,34 @@ static inline void b43_piorx_write32(str
+@@ -150,7 +150,7 @@ static inline void b43_piorx_write32(str
+       b43_write32(q->dev, q->mmio_base + offset, value);
  }
  
+-
++#ifdef CONFIG_B43_PIO
+ int b43_pio_init(struct b43_wldev *dev);
+ void b43_pio_free(struct b43_wldev *dev);
  
--int b43_pio_init(struct b43_wldev *dev);
--void b43_pio_free(struct b43_wldev *dev);
+@@ -161,5 +161,37 @@ void b43_pio_rx(struct b43_pio_rxqueue *
+ void b43_pio_tx_suspend(struct b43_wldev *dev);
+ void b43_pio_tx_resume(struct b43_wldev *dev);
++#else
 +static inline int b43_pio_init(struct b43_wldev *dev)
 +{
 +      return 0;
 +{
 +      return 0;
 +}
--int b43_pio_tx(struct b43_wldev *dev, struct sk_buff *skb);
--void b43_pio_handle_txstatus(struct b43_wldev *dev,
--                           const struct b43_txstatus *status);
--void b43_pio_rx(struct b43_pio_rxqueue *q);
++
 +static inline void b43_pio_handle_txstatus(struct b43_wldev *dev,
 +                                         const struct b43_txstatus *status)
 +{
 +static inline void b43_pio_rx(struct b43_pio_rxqueue *q)
 +{
 +}
--void b43_pio_tx_suspend(struct b43_wldev *dev);
--void b43_pio_tx_resume(struct b43_wldev *dev);
++
 +static inline void b43_pio_tx_suspend(struct b43_wldev *dev)
 +{
 +}
++
 +static inline void b43_pio_tx_resume(struct b43_wldev *dev)
 +{
 +}
++#endif /* CONFIG_B43_PIO */
  
  #endif /* B43_PIO_H_ */