madwifi: select the right hal binary for EABI on ARM
[openwrt/svn-archive/archive.git] / package / madwifi / Makefile
index adfd418b20b606fcbcfc74135acf204ef2ed51a0..a0934691eaa0f853d3bfda14f99c053fb1cdb41c 100644 (file)
@@ -63,10 +63,10 @@ ifneq ($(CONFIG_CPU_MIPS32_R2),)
   endif
 else
   ifeq ($(ARCH),mips)
-    HAL_TARGET:=mips32-be-elf
+    HAL_TARGET:=$(if $(CONFIG_MADWIFI_UPSTREAM),mips-be-elf,mips32-be-elf)
   endif
   ifeq ($(ARCH),mipsel)
-    HAL_TARGET:=mips32-le-elf
+    HAL_TARGET:=$(if $(CONFIG_MADWIFI_UPSTREAM),mips-le-elf,mips32-le-elf)
   endif
 endif
 ifeq ($(ARCH),i386)
@@ -76,19 +76,19 @@ ifeq ($(ARCH),i686)
   HAL_TARGET:=i386-elf
 endif
 ifeq ($(BOARD),ixp4xx)
-  HAL_TARGET:=xscale-be-elf
+  HAL_TARGET:=xscale-be-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
 endif
 ifeq ($(BOARD),iop32x)
-  HAL_TARGET:=xscale-le-elf
+  HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
 endif
 ifeq ($(BOARD),orion)
-  HAL_TARGET:=xscale-le-elf
+  HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
 endif
 ifeq ($(ARCH),powerpc)
   HAL_TARGET:=powerpc-be-elf
 endif
 ifeq ($(BOARD),storm)
-  HAL_TARGET:=armv4-le-elf
+  HAL_TARGET:=armv4-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
 endif
 ifneq ($(CONFIG_TARGET_atheros),)
   HAL_TARGET:=wisoc