This patch adds a number of configuration options to the MadWifi package. You can
[openwrt/svn-archive/archive.git] / package / madwifi / Makefile
index ad7f5c9ba3c2e2f2e5f9572e17b4683d3cedc11b..ef83702a8aee12c3fe5a92cbdda966d63d8a2e19 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,60 +10,130 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=madwifi
-PKG_REV:=3252
+PKG_REV:=3314
 PKG_VERSION:=r$(PKG_REV)
-PKG_BRANCH:=madwifi-dfs
+PKG_BRANCH:=madwifi-dfs
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
-PKG_SOURCE_SUBDIR:=$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi)-$(PKG_VERSION)
+PKG_SOURCE_SUBDIR:=$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi-trunk)-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://svn.madwifi.org/madwifi/$(if $(PKG_BRANCH),branches/$(PKG_BRANCH),trunk)
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
 
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BRANCH)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi-trunk)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
-# MADWIFI_DEBUG=1
+ifdef CONFIG_MADWIFI_BUS_DEFAULT
+  ifneq ($(CONFIG_TARGET_atheros),)
+    BUS:=AHB
+  else
+    ifneq ($(CONFIG_PCI_SUPPORT),)
+      BUS:=PCI
+    endif
+  endif
 
-ifeq ($(ARCH),mips)
-  HAL_TARGET:=mips-be-elf
-endif
-ifeq ($(ARCH),mipsel)
-  HAL_TARGET:=mips-le-elf
-endif
-ifeq ($(ARCH),i386)
-  HAL_TARGET:=i386-elf
-endif
-ifeq ($(ARCH),i686)
-  HAL_TARGET:=i386-elf
-endif
-ifeq ($(ARCH),armeb)
-  HAL_TARGET:=xscale-be-elf
-endif
-ifeq ($(ARCH),arm)
-  HAL_TARGET:=xscale-le-elf
-endif
-ifeq ($(ARCH),powerpc)
-  HAL_TARGET:=powerpc-be-elf
+  # XXX: remove this check later when we have PCI support properly detected on all targets
+  ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
+    BUS:=
+  endif
+else
+  ifdef CONFIG_MADWIFI_BUS_PCI
+    BUS:=PCI
+  else
+    ifdef CONFIG_MADWIFI_BUS_AHB
+      BUS:=AHB
+    endif
+  endif
 endif
 
-ifneq ($(CONFIG_TARGET_atheros),)
-  BUS:=AHB
-  HAL_TARGET:=ap51
+ifdef CONFIG_MADWIFI_HAL_DEFAULT
+  ifeq ($(ARCH),mips)
+    HAL_TARGET:=mips-be-elf
+  endif
+  ifeq ($(ARCH),mipsel)
+    HAL_TARGET:=mips-le-elf
+  endif
+  ifeq ($(ARCH),i386)
+    HAL_TARGET:=i386-elf
+  endif
+  ifeq ($(ARCH),i686)
+    HAL_TARGET:=i386-elf
+  endif
+  ifeq ($(BOARD),ixp4xx)
+    HAL_TARGET:=xscale-be-elf
+  endif
+  ifeq ($(BOARD),iop32x)
+    HAL_TARGET:=xscale-le-elf
+  endif
+  ifeq ($(ARCH),powerpc)
+    HAL_TARGET:=powerpc-be-elf
+  endif
+  ifeq ($(BOARD),storm)
+    HAL_TARGET:=armv4-le-elf
+  endif
+  ifneq ($(CONFIG_TARGET_atheros),)
+    HAL_TARGET:=ap51
+  endif
 else
-  ifneq ($(CONFIG_PCI_SUPPORT),)
-    BUS:=PCI
+  ifdef CONFIG_MADWIFI_HAL_MIPS_BE_ELF
+    HAL_TARGET:=mips-be-elf
+  endif
+
+  ifdef CONFIG_MADWIFI_HAL_MIPS_LE_ELF
+    HAL_TARGET:=mips-le-elf
+  endif
+
+  ifdef CONFIG_MADWIFI_HAL_I386_ELF
+    HAL_TARGET:=i386-elf
   endif
+
+  ifdef CONFIG_MADWIFI_HAL_XSCALE_BE_ELF
+    HAL_TARGET:=xscale-be-elf
+  endif
+
+  ifdef CONFIG_MADWIFI_HAL_XSCALE_LE_ELF
+    HAL_TARGET:=xscale-le-elf
+  endif
+
+  ifdef CONFIG_MADWIFI_HAL_ARMV4_LE_ELF
+    HAL_TARGET:=armv4-le-elf
+  endif
+
+  ifdef CONFIG_MADWIFI_HAL_AP30
+    HAL_TARGET:=ap30
+  endif
+
+  ifdef CONFIG_MADWIFI_HAL_AP43
+    HAL_TARGET:=ap43
+  endif
+
+  ifdef CONFIG_MADWIFI_HAL_AP51
+    HAL_TARGET:=ap51
+  endif
+
+  ifdef CONFIG_MADWIFI_HAL_AP61
+    HAL_TARGET:=ap61
+  endif
+
+endif
+
+ifdef CONFIG_MADWIFI_RCA_MINSTREL
+  RATE_CONTROL:=minstrel
+endif
+
+ifdef CONFIG_MADWIFI_RCA_ONOE
+  RATE_CONTROL:=onoe
 endif
 
-# XXX: remove this check later when we have PCI support properly detected on all targets
-ifneq ($(CONFIG_TARGET_uml),)
- BUS:=
+ifdef CONFIG_MADWIFI_RCA_AMRR
+  RATE_CONTROL:=amrr
 endif
 
-RATE_CONTROL:=minstrel
+ifdef CONFIG_MADWIFI_RCA_SAMPLERATE
+  RATE_CONTROL:=sample
+endif
 
 MADWIFI_FILES:= \
        $(PKG_BUILD_DIR)/net80211/wlan.$(LINUX_KMOD_SUFFIX) \
@@ -99,7 +169,7 @@ ifeq ($(findstring PCI,$(BUS)),PCI)
 endif
 
 MADWIFI_APPLETS:=80211stats,athchans,athctrl,athkey,athstats,wlanconfig
-ifneq ($(MADWIFI_DEBUG),)
+ifdef CONFIG_MADWIFI_DEBUG
   MADWIFI_APPLETS:=$(strip $(MADWIFI_APPLETS)),athdebug,80211debug
 endif
 
@@ -108,7 +178,7 @@ define KernelPackage/madwifi
   SUBMENU:=Wireless Drivers
   TITLE:=Driver for Atheros wireless chipsets
   URL:=http://madwifi.org/
-  DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
+  DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_ar7 @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
   FILES:=$(MADWIFI_FILES)
   AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
 endef
@@ -117,6 +187,13 @@ define KernelPackage/madwifi/description
  This package contains a driver for Atheros 802.11a/b/g chipsets.
 endef
 
+define KernelPackage/madwifi/config
+       menu "MadWifi Configuration"
+               depends on PACKAGE_kmod-madwifi
+               source "$(SOURCE)/Config.in"
+       endmenu
+endef
+
 MAKE_ARGS:= \
        PATH="$(TARGET_PATH)" \
        ARCH="$(LINUX_KARCH)" \
@@ -128,12 +205,24 @@ MAKE_ARGS:= \
        LDOPTS="--no-warn-mismatch " \
        ATH_RATE="ath_rate/$(RATE_CONTROL)" \
        WARNINGS="-Wno-unused" \
-       $(if $(MADWIFI_DEBUG),,DEBUG="") \
+       $(ifndef CONFIG_MADWIFI_DEBUG,DEBUG="") \
        DOMULTI=1
 
 MAKE_VARS:= \
        COPTS="-DCONFIG_ATHEROS_RATE_DEFAULT='\"$(RATE_CONTROL)\"'" \
 
+HALFILE:=$(lastword $(sort $(wildcard ./ath_hal-*.tgz)))
+ifneq ($(HALFILE),)
+  define Build/Prepare
+       $(call Build/Prepare/Default)
+       rm -rf $(PKG_BUILD_DIR)/tmp
+       mkdir -p $(PKG_BUILD_DIR)/tmp
+       tar xvzf $(HALFILE) -C $(PKG_BUILD_DIR)/tmp
+       $(CP) $(PKG_BUILD_DIR)/tmp/ath_hal*/* $(PKG_BUILD_DIR)/hal/
+       rm -rf $(PKG_BUILD_DIR)/tmp
+  endef
+endif
+
 ifeq ($(findstring AHB,$(BUS)),AHB)
   define Build/Compile/ahb
        $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_ARGS) BUS="AHB" modules