refresh madwifi patches
[openwrt/svn-archive/archive.git] / package / madwifi / patches / 200-no_debug.patch
index 71675e5a1164122080a65629cac75d0d53ca5f5f..051b1fdd6cbd764fa65e8750c26842ba7f37f759 100644 (file)
@@ -1,7 +1,7 @@
-Index: madwifi-ng-r2525-20070630/ath/if_ath.c
+Index: madwifi-ng-r2568-20070710/ath/if_ath.c
 ===================================================================
---- madwifi-ng-r2525-20070630.orig/ath/if_ath.c        2007-07-03 23:02:30.957978500 +0200
-+++ madwifi-ng-r2525-20070630/ath/if_ath.c     2007-07-03 23:02:32.178054750 +0200
+--- madwifi-ng-r2568-20070710.orig/ath/if_ath.c        2007-07-13 11:18:19.221391908 +0200
++++ madwifi-ng-r2568-20070710/ath/if_ath.c     2007-07-13 11:18:19.473406270 +0200
 @@ -75,7 +75,7 @@
  #include <net80211/if_llc.h>
  #endif
@@ -11,10 +11,10 @@ Index: madwifi-ng-r2525-20070630/ath/if_ath.c
  
  #include "net80211/if_athproto.h"
  #include "if_athvar.h"
-Index: madwifi-ng-r2525-20070630/ath_rate/amrr/amrr.c
+Index: madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c
 ===================================================================
---- madwifi-ng-r2525-20070630.orig/ath_rate/amrr/amrr.c        2007-07-03 23:02:25.053609500 +0200
-+++ madwifi-ng-r2525-20070630/ath_rate/amrr/amrr.c     2007-07-03 23:02:32.178054750 +0200
+--- madwifi-ng-r2568-20070710.orig/ath_rate/amrr/amrr.c        2007-07-13 11:18:13.277053162 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c     2007-07-13 11:18:19.473406270 +0200
 @@ -70,7 +70,7 @@
  
  #include "amrr.h"
@@ -24,10 +24,10 @@ Index: madwifi-ng-r2525-20070630/ath_rate/amrr/amrr.c
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-Index: madwifi-ng-r2525-20070630/ath_rate/minstrel/minstrel.c
+Index: madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c
 ===================================================================
---- madwifi-ng-r2525-20070630.orig/ath_rate/minstrel/minstrel.c        2007-07-03 23:02:30.209931750 +0200
-+++ madwifi-ng-r2525-20070630/ath_rate/minstrel/minstrel.c     2007-07-03 23:02:32.230058000 +0200
+--- madwifi-ng-r2568-20070710.orig/ath_rate/minstrel/minstrel.c        2007-07-13 11:18:16.433233021 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c     2007-07-13 11:18:19.497407640 +0200
 @@ -117,7 +117,7 @@
  
  #include "minstrel.h"
@@ -37,10 +37,10 @@ Index: madwifi-ng-r2525-20070630/ath_rate/minstrel/minstrel.c
  #ifdef MINSTREL_DEBUG
  enum {
                ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-Index: madwifi-ng-r2525-20070630/ath_rate/onoe/onoe.c
+Index: madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c
 ===================================================================
---- madwifi-ng-r2525-20070630.orig/ath_rate/onoe/onoe.c        2007-07-03 23:02:25.073610750 +0200
-+++ madwifi-ng-r2525-20070630/ath_rate/onoe/onoe.c     2007-07-03 23:02:32.254059500 +0200
+--- madwifi-ng-r2568-20070710.orig/ath_rate/onoe/onoe.c        2007-07-13 11:18:13.293054074 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c     2007-07-13 11:18:19.525409234 +0200
 @@ -66,7 +66,7 @@
  
  #include "onoe.h"
@@ -50,10 +50,10 @@ Index: madwifi-ng-r2525-20070630/ath_rate/onoe/onoe.c
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-Index: madwifi-ng-r2525-20070630/ath_rate/sample/sample.c
+Index: madwifi-ng-r2568-20070710/ath_rate/sample/sample.c
 ===================================================================
---- madwifi-ng-r2525-20070630.orig/ath_rate/sample/sample.c    2007-07-03 23:02:25.081611250 +0200
-+++ madwifi-ng-r2525-20070630/ath_rate/sample/sample.c 2007-07-03 23:02:32.282061250 +0200
+--- madwifi-ng-r2568-20070710.orig/ath_rate/sample/sample.c    2007-07-13 11:18:13.301054529 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/sample/sample.c 2007-07-13 11:18:19.549410604 +0200
 @@ -68,7 +68,7 @@
  
  #include "sample.h"
@@ -63,10 +63,10 @@ Index: madwifi-ng-r2525-20070630/ath_rate/sample/sample.c
  #ifdef SAMPLE_DEBUG
  enum {
        ATH_DEBUG_NODE          = 0x00080000,   /* node management */
-Index: madwifi-ng-r2525-20070630/net80211/ieee80211_proto.c
+Index: madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c
 ===================================================================
---- madwifi-ng-r2525-20070630.orig/net80211/ieee80211_proto.c  2007-07-03 23:02:25.089611750 +0200
-+++ madwifi-ng-r2525-20070630/net80211/ieee80211_proto.c       2007-07-03 23:02:32.306062750 +0200
+--- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_proto.c  2007-07-13 11:18:13.309054985 +0200
++++ madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c       2007-07-13 11:18:19.601413567 +0200
 @@ -286,6 +286,7 @@
  }
  EXPORT_SYMBOL(ieee80211_aclator_get);
@@ -83,10 +83,10 @@ Index: madwifi-ng-r2525-20070630/net80211/ieee80211_proto.c
  void
  ieee80211_dump_pkt(struct ieee80211com *ic,
        const u_int8_t *buf, int len, int rate, int rssi)
-Index: madwifi-ng-r2525-20070630/net80211/ieee80211_var.h
+Index: madwifi-ng-r2568-20070710/net80211/ieee80211_var.h
 ===================================================================
---- madwifi-ng-r2525-20070630.orig/net80211/ieee80211_var.h    2007-07-03 23:02:25.101612500 +0200
-+++ madwifi-ng-r2525-20070630/net80211/ieee80211_var.h 2007-07-03 23:02:32.330064250 +0200
+--- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_var.h    2007-07-13 11:18:13.317055440 +0200
++++ madwifi-ng-r2568-20070710/net80211/ieee80211_var.h 2007-07-13 11:18:19.625414935 +0200
 @@ -35,8 +35,8 @@
  #ifndef _NET80211_IEEE80211_VAR_H_
  #define _NET80211_IEEE80211_VAR_H_
@@ -98,10 +98,10 @@ Index: madwifi-ng-r2525-20070630/net80211/ieee80211_var.h
  
  /* Definitions for IEEE 802.11 drivers. */
  #include <net80211/ieee80211_linux.h>
-Index: madwifi-ng-r2525-20070630/tools/do_multi.c
+Index: madwifi-ng-r2568-20070710/tools/do_multi.c
 ===================================================================
---- madwifi-ng-r2525-20070630.orig/tools/do_multi.c    2007-07-03 23:02:27.557766000 +0200
-+++ madwifi-ng-r2525-20070630/tools/do_multi.c 2007-07-03 23:02:32.386067750 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/do_multi.c    2007-07-13 11:18:15.265166457 +0200
++++ madwifi-ng-r2568-20070710/tools/do_multi.c 2007-07-13 11:18:19.653416531 +0200
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -123,10 +123,10 @@ Index: madwifi-ng-r2525-20070630/tools/do_multi.c
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-Index: madwifi-ng-r2525-20070630/tools/Makefile
+Index: madwifi-ng-r2568-20070710/tools/Makefile
 ===================================================================
---- madwifi-ng-r2525-20070630.orig/tools/Makefile      2007-07-03 23:02:27.605769000 +0200
-+++ madwifi-ng-r2525-20070630/tools/Makefile   2007-07-03 23:02:32.406069000 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/Makefile      2007-07-13 11:18:15.313169194 +0200
++++ madwifi-ng-r2568-20070710/tools/Makefile   2007-07-13 11:18:19.673417671 +0200
 @@ -52,7 +52,7 @@
        
  ifdef DOMULTI