refresh madwifi patches
[openwrt/svn-archive/archive.git] / package / madwifi / patches / 200-no_debug.patch
index cd733509392568d4e5a071f00ca5338fc93cb95d..051b1fdd6cbd764fa65e8750c26842ba7f37f759 100644 (file)
@@ -1,19 +1,21 @@
-diff -Nur madwifi-0.9.2.1/ath/if_ath.c madwifi-0.9.2.1-nodebug/ath/if_ath.c
---- madwifi-0.9.2.1/ath/if_ath.c       2006-07-08 08:47:19.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/ath/if_ath.c       2007-02-20 11:48:05.000000000 +0100
-@@ -72,7 +72,7 @@
+Index: madwifi-ng-r2568-20070710/ath/if_ath.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath/if_ath.c        2007-07-13 11:18:19.221391908 +0200
++++ madwifi-ng-r2568-20070710/ath/if_ath.c     2007-07-13 11:18:19.473406270 +0200
+@@ -75,7 +75,7 @@
  #include <net80211/if_llc.h>
  #endif
  
 -#define       AR_DEBUG
 +#undef        AR_DEBUG
  
- #include "if_athrate.h"
  #include "net80211/if_athproto.h"
-diff -Nur madwifi-0.9.2.1/ath_rate/amrr/amrr.c madwifi-0.9.2.1-nodebug/ath_rate/amrr/amrr.c
---- madwifi-0.9.2.1/ath_rate/amrr/amrr.c       2006-07-04 12:23:35.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/ath_rate/amrr/amrr.c       2007-02-20 11:49:10.000000000 +0100
-@@ -67,7 +67,7 @@
+ #include "if_athvar.h"
+Index: madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath_rate/amrr/amrr.c        2007-07-13 11:18:13.277053162 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c     2007-07-13 11:18:19.473406270 +0200
+@@ -70,7 +70,7 @@
  
  #include "amrr.h"
  
@@ -22,10 +24,24 @@ diff -Nur madwifi-0.9.2.1/ath_rate/amrr/amrr.c madwifi-0.9.2.1-nodebug/ath_rate/
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-diff -Nur madwifi-0.9.2.1/ath_rate/onoe/onoe.c madwifi-0.9.2.1-nodebug/ath_rate/onoe/onoe.c
---- madwifi-0.9.2.1/ath_rate/onoe/onoe.c       2006-07-04 12:23:35.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/ath_rate/onoe/onoe.c       2007-02-20 11:48:51.000000000 +0100
-@@ -63,7 +63,7 @@
+Index: madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath_rate/minstrel/minstrel.c        2007-07-13 11:18:16.433233021 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c     2007-07-13 11:18:19.497407640 +0200
+@@ -117,7 +117,7 @@
+ #include "minstrel.h"
+-#define       MINSTREL_DEBUG
++#undef        MINSTREL_DEBUG
+ #ifdef MINSTREL_DEBUG
+ enum {
+               ATH_DEBUG_RATE          = 0x00000010    /* rate control */
+Index: madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath_rate/onoe/onoe.c        2007-07-13 11:18:13.293054074 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c     2007-07-13 11:18:19.525409234 +0200
+@@ -66,7 +66,7 @@
  
  #include "onoe.h"
  
@@ -34,10 +50,11 @@ diff -Nur madwifi-0.9.2.1/ath_rate/onoe/onoe.c madwifi-0.9.2.1-nodebug/ath_rate/
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-diff -Nur madwifi-0.9.2.1/ath_rate/sample/sample.c madwifi-0.9.2.1-nodebug/ath_rate/sample/sample.c
---- madwifi-0.9.2.1/ath_rate/sample/sample.c   2006-07-04 12:23:35.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/ath_rate/sample/sample.c   2007-02-20 11:48:31.000000000 +0100
-@@ -65,7 +65,7 @@
+Index: madwifi-ng-r2568-20070710/ath_rate/sample/sample.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath_rate/sample/sample.c    2007-07-13 11:18:13.301054529 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/sample/sample.c 2007-07-13 11:18:19.549410604 +0200
+@@ -68,7 +68,7 @@
  
  #include "sample.h"
  
@@ -45,22 +62,46 @@ diff -Nur madwifi-0.9.2.1/ath_rate/sample/sample.c madwifi-0.9.2.1-nodebug/ath_r
 +#undef        SAMPLE_DEBUG
  #ifdef SAMPLE_DEBUG
  enum {
-       ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-diff -Nur madwifi-0.9.2.1/net80211/ieee80211_var.h madwifi-0.9.2.1-nodebug/net80211/ieee80211_var.h
---- madwifi-0.9.2.1/net80211/ieee80211_var.h   2006-07-06 05:23:08.000000000 +0200
-+++ madwifi-0.9.2.1-nodebug/net80211/ieee80211_var.h   2007-02-20 11:43:09.000000000 +0100
-@@ -37,7 +37,7 @@
- /*
-  * Definitions for IEEE 802.11 drivers.
-  */
+       ATH_DEBUG_NODE          = 0x00080000,   /* node management */
+Index: madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_proto.c  2007-07-13 11:18:13.309054985 +0200
++++ madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c       2007-07-13 11:18:19.601413567 +0200
+@@ -286,6 +286,7 @@
+ }
+ EXPORT_SYMBOL(ieee80211_aclator_get);
++#ifdef IEEE80211_DEBUG
+ void
+ ieee80211_print_essid(const u_int8_t *essid, int len)
+ {
+@@ -312,7 +313,6 @@
+ }
+ EXPORT_SYMBOL(ieee80211_print_essid);
+-#ifdef IEEE80211_DEBUG
+ void
+ ieee80211_dump_pkt(struct ieee80211com *ic,
+       const u_int8_t *buf, int len, int rate, int rssi)
+Index: madwifi-ng-r2568-20070710/net80211/ieee80211_var.h
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_var.h    2007-07-13 11:18:13.317055440 +0200
++++ madwifi-ng-r2568-20070710/net80211/ieee80211_var.h 2007-07-13 11:18:19.625414935 +0200
+@@ -35,8 +35,8 @@
+ #ifndef _NET80211_IEEE80211_VAR_H_
+ #define _NET80211_IEEE80211_VAR_H_
 -#define       IEEE80211_DEBUG
+-#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
 +#undef        IEEE80211_DEBUG
- #undef        IEEE80211_DEBUG_REFCNT                  /* node refcnt stuff */
++#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
  
+ /* Definitions for IEEE 802.11 drivers. */
  #include <net80211/ieee80211_linux.h>
-diff -Nur madwifi-0.9.2.1/tools/do_multi.c madwifi-0.9.2.1-nodebug/tools/do_multi.c
---- madwifi-0.9.2.1/tools/do_multi.c   2007-02-20 11:53:44.000000000 +0100
-+++ madwifi-0.9.2.1-nodebug/tools/do_multi.c   2007-02-20 11:58:22.000000000 +0100
+Index: madwifi-ng-r2568-20070710/tools/do_multi.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/tools/do_multi.c    2007-07-13 11:18:15.265166457 +0200
++++ madwifi-ng-r2568-20070710/tools/do_multi.c 2007-07-13 11:18:19.653416531 +0200
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -82,15 +123,16 @@ diff -Nur madwifi-0.9.2.1/tools/do_multi.c madwifi-0.9.2.1-nodebug/tools/do_mult
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-diff -Nur madwifi-0.9.2.1/tools/Makefile madwifi-0.9.2.1-nodebug/tools/Makefile
---- madwifi-0.9.2.1/tools/Makefile     2007-02-20 11:53:44.000000000 +0100
-+++ madwifi-0.9.2.1-nodebug/tools/Makefile     2007-02-20 11:57:23.000000000 +0100
+Index: madwifi-ng-r2568-20070710/tools/Makefile
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/tools/Makefile      2007-07-13 11:18:15.313169194 +0200
++++ madwifi-ng-r2568-20070710/tools/Makefile   2007-07-13 11:18:19.673417671 +0200
 @@ -52,7 +52,7 @@
        
  ifdef DOMULTI
  OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
 -      athdebug.o 80211debug.o wlanconfig.o 
-+      wlanconfig.o 
++      wlanconfig.o
  ALL=  ${OBJS} madwifi_multi
  endif