update madwifi to latest rev - works around some crashiness
[openwrt/svn-archive/archive.git] / package / madwifi / patches / 200-no_debug.patch
index 89b46082dc3e32d8bc869fe803287088a4cf5cc4..21e9ba07c8fbf890784428e8f84eb4c5c57c99d1 100644 (file)
@@ -1,28 +1,21 @@
-diff -ur madwifi.old/ath/if_ath.c madwifi.dev/ath/if_ath.c
---- madwifi.old/ath/if_ath.c   2007-02-20 22:50:52.277096688 +0100
-+++ madwifi.dev/ath/if_ath.c   2007-02-20 22:53:50.476006336 +0100
-@@ -72,7 +72,7 @@
+Index: madwifi-ng-r2834-20071106/ath/if_ath.c
+===================================================================
+--- madwifi-ng-r2834-20071106.orig/ath/if_ath.c        2007-11-07 14:02:04.077603246 +0100
++++ madwifi-ng-r2834-20071106/ath/if_ath.c     2007-11-07 14:02:04.537629461 +0100
+@@ -75,7 +75,7 @@
  #include <net80211/if_llc.h>
  #endif
  
 -#define       AR_DEBUG
 +#undef        AR_DEBUG
  
- #include "if_athrate.h"
  #include "net80211/if_athproto.h"
-@@ -347,7 +347,7 @@
-               ath_keyprint(__func__, ix, hk, mac);            \
- } while (0)
- #else /* defined(AR_DEBUG) */
--#define       IFF_DUMPPKTS(sc, _m)    netif_msg_dumppkts(&sc->sc_ic)
-+#define       IFF_DUMPPKTS(sc, _m)    0
- #define       DPRINTF(sc, _m, _fmt, ...)
- #define       KEYPRINTF(sc, k, ix, mac)
- #endif /* defined(AR_DEBUG) */
-diff -ur madwifi.old/ath_rate/amrr/amrr.c madwifi.dev/ath_rate/amrr/amrr.c
---- madwifi.old/ath_rate/amrr/amrr.c   2007-02-20 22:50:52.278096536 +0100
-+++ madwifi.dev/ath_rate/amrr/amrr.c   2007-02-20 22:50:31.652232144 +0100
-@@ -67,7 +67,7 @@
+ #include "if_athvar.h"
+Index: madwifi-ng-r2834-20071106/ath_rate/amrr/amrr.c
+===================================================================
+--- madwifi-ng-r2834-20071106.orig/ath_rate/amrr/amrr.c        2007-11-07 14:01:59.177323993 +0100
++++ madwifi-ng-r2834-20071106/ath_rate/amrr/amrr.c     2007-11-07 14:02:04.545629914 +0100
+@@ -70,7 +70,7 @@
  
  #include "amrr.h"
  
@@ -31,10 +24,24 @@ diff -ur madwifi.old/ath_rate/amrr/amrr.c madwifi.dev/ath_rate/amrr/amrr.c
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-diff -ur madwifi.old/ath_rate/onoe/onoe.c madwifi.dev/ath_rate/onoe/onoe.c
---- madwifi.old/ath_rate/onoe/onoe.c   2007-02-20 22:50:52.278096536 +0100
-+++ madwifi.dev/ath_rate/onoe/onoe.c   2007-02-20 22:50:31.653231992 +0100
-@@ -63,7 +63,7 @@
+Index: madwifi-ng-r2834-20071106/ath_rate/minstrel/minstrel.c
+===================================================================
+--- madwifi-ng-r2834-20071106.orig/ath_rate/minstrel/minstrel.c        2007-11-07 14:02:01.169437517 +0100
++++ madwifi-ng-r2834-20071106/ath_rate/minstrel/minstrel.c     2007-11-07 14:02:04.549630142 +0100
+@@ -117,7 +117,7 @@
+ #include "minstrel.h"
+-#define       MINSTREL_DEBUG
++#undef        MINSTREL_DEBUG
+ #ifdef MINSTREL_DEBUG
+ enum {
+               ATH_DEBUG_RATE          = 0x00000010    /* rate control */
+Index: madwifi-ng-r2834-20071106/ath_rate/onoe/onoe.c
+===================================================================
+--- madwifi-ng-r2834-20071106.orig/ath_rate/onoe/onoe.c        2007-11-07 14:01:59.193324906 +0100
++++ madwifi-ng-r2834-20071106/ath_rate/onoe/onoe.c     2007-11-07 14:02:04.553630371 +0100
+@@ -66,7 +66,7 @@
  
  #include "onoe.h"
  
@@ -43,10 +50,11 @@ diff -ur madwifi.old/ath_rate/onoe/onoe.c madwifi.dev/ath_rate/onoe/onoe.c
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-diff -ur madwifi.old/ath_rate/sample/sample.c madwifi.dev/ath_rate/sample/sample.c
---- madwifi.old/ath_rate/sample/sample.c       2007-02-20 22:50:52.278096536 +0100
-+++ madwifi.dev/ath_rate/sample/sample.c       2007-02-20 22:50:31.653231992 +0100
-@@ -65,7 +65,7 @@
+Index: madwifi-ng-r2834-20071106/ath_rate/sample/sample.c
+===================================================================
+--- madwifi-ng-r2834-20071106.orig/ath_rate/sample/sample.c    2007-11-07 14:01:59.201325359 +0100
++++ madwifi-ng-r2834-20071106/ath_rate/sample/sample.c 2007-11-07 14:02:04.557630601 +0100
+@@ -68,7 +68,7 @@
  
  #include "sample.h"
  
@@ -54,22 +62,26 @@ diff -ur madwifi.old/ath_rate/sample/sample.c madwifi.dev/ath_rate/sample/sample
 +#undef        SAMPLE_DEBUG
  #ifdef SAMPLE_DEBUG
  enum {
-       ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-diff -ur madwifi.old/net80211/ieee80211_var.h madwifi.dev/net80211/ieee80211_var.h
---- madwifi.old/net80211/ieee80211_var.h       2007-02-20 22:50:52.279096384 +0100
-+++ madwifi.dev/net80211/ieee80211_var.h       2007-02-20 22:50:31.654231840 +0100
-@@ -37,7 +37,7 @@
- /*
-  * Definitions for IEEE 802.11 drivers.
-  */
+       ATH_DEBUG_NODE          = 0x00080000,   /* node management */
+Index: madwifi-ng-r2834-20071106/net80211/ieee80211_var.h
+===================================================================
+--- madwifi-ng-r2834-20071106.orig/net80211/ieee80211_var.h    2007-11-07 14:01:59.209325817 +0100
++++ madwifi-ng-r2834-20071106/net80211/ieee80211_var.h 2007-11-07 14:02:04.561630827 +0100
+@@ -35,8 +35,8 @@
+ #ifndef _NET80211_IEEE80211_VAR_H_
+ #define _NET80211_IEEE80211_VAR_H_
 -#define       IEEE80211_DEBUG
+-#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
 +#undef        IEEE80211_DEBUG
- #undef        IEEE80211_DEBUG_REFCNT                  /* node refcnt stuff */
++#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
  
+ /* Definitions for IEEE 802.11 drivers. */
  #include <net80211/ieee80211_linux.h>
-diff -ur madwifi.old/tools/do_multi.c madwifi.dev/tools/do_multi.c
---- madwifi.old/tools/do_multi.c       2007-02-20 22:50:52.279096384 +0100
-+++ madwifi.dev/tools/do_multi.c       2007-02-20 22:50:31.654231840 +0100
+Index: madwifi-ng-r2834-20071106/tools/do_multi.c
+===================================================================
+--- madwifi-ng-r2834-20071106.orig/tools/do_multi.c    2007-11-07 14:02:00.197382122 +0100
++++ madwifi-ng-r2834-20071106/tools/do_multi.c 2007-11-07 14:02:04.565631053 +0100
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -91,21 +103,22 @@ diff -ur madwifi.old/tools/do_multi.c madwifi.dev/tools/do_multi.c
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-diff -ur madwifi.old/tools/Makefile madwifi.dev/tools/Makefile
---- madwifi.old/tools/Makefile 2007-02-20 22:50:52.279096384 +0100
-+++ madwifi.dev/tools/Makefile 2007-02-20 22:50:31.654231840 +0100
-@@ -52,7 +52,7 @@
-       
- ifdef DOMULTI
- OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
--      athdebug.o 80211debug.o wlanconfig.o 
-+      wlanconfig.o 
- ALL=  ${OBJS} madwifi_multi
- endif
+Index: madwifi-ng-r2834-20071106/tools/Makefile
+===================================================================
+--- madwifi-ng-r2834-20071106.orig/tools/Makefile      2007-11-07 14:02:00.197382122 +0100
++++ madwifi-ng-r2834-20071106/tools/Makefile   2007-11-07 14:02:04.565631053 +0100
+@@ -48,7 +48,7 @@
  
-@@ -85,7 +85,7 @@
+ ALLPROGS=     athstats 80211stats athkey athchans athctrl \
+-      athdebug 80211debug wlanconfig ath_info
++      wlanconfig ath_info
+ OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
+ ALL=  ${OBJS} madwifi_multi
+@@ -84,7 +84,7 @@
        ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
- madwifi_multi:
+ madwifi_multi: $(OBJS)
        ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
 -      for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
 +      for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \