sync with latest madwifi snapshot, refresh patches, add tpc fix by mdtaylor (should...
[openwrt/svn-archive/archive.git] / package / madwifi / patches / 200-no_debug.patch
index 6a739294208fb4e6a1449ac43ffb5bf0d98256cb..d3461166e0463946a071d18be5251b4ef8166385 100644 (file)
@@ -1,6 +1,7 @@
-diff -urN madwifi-ng-r2377-20070526.old/ath/if_ath.c madwifi-ng-r2377-20070526.dev/ath/if_ath.c
---- madwifi-ng-r2377-20070526.old/ath/if_ath.c 2007-05-26 18:51:09.199688976 +0200
-+++ madwifi-ng-r2377-20070526.dev/ath/if_ath.c 2007-05-26 18:51:09.207687760 +0200
+Index: madwifi-ng-r2568-20070710/ath/if_ath.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath/if_ath.c        2007-07-11 22:59:44.052358947 +0200
++++ madwifi-ng-r2568-20070710/ath/if_ath.c     2007-07-11 22:59:44.300373081 +0200
 @@ -75,7 +75,7 @@
  #include <net80211/if_llc.h>
  #endif
@@ -10,19 +11,11 @@ diff -urN madwifi-ng-r2377-20070526.old/ath/if_ath.c madwifi-ng-r2377-20070526.d
  
  #include "net80211/if_athproto.h"
  #include "if_athvar.h"
-@@ -368,7 +368,7 @@
-               ath_keyprint(sc, __func__, ix, hk, mac);        \
- } while (0)
- #else /* defined(AR_DEBUG) */
--#define       IFF_DUMPPKTS(sc, _m)    netif_msg_dumppkts(&sc->sc_ic)
-+#define       IFF_DUMPPKTS(sc, _m)    0
- #define       DPRINTF(sc, _m, _fmt, ...)
- #define       KEYPRINTF(sc, k, ix, mac)
- #endif /* defined(AR_DEBUG) */
-diff -urN madwifi-ng-r2377-20070526.old/ath_rate/amrr/amrr.c madwifi-ng-r2377-20070526.dev/ath_rate/amrr/amrr.c
---- madwifi-ng-r2377-20070526.old/ath_rate/amrr/amrr.c 2007-05-21 19:33:26.000000000 +0200
-+++ madwifi-ng-r2377-20070526.dev/ath_rate/amrr/amrr.c 2007-05-26 18:51:09.208687608 +0200
-@@ -69,7 +69,7 @@
+Index: madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath_rate/amrr/amrr.c        2007-07-11 22:59:38.296030912 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/amrr/amrr.c     2007-07-11 22:59:44.304373307 +0200
+@@ -70,7 +70,7 @@
  
  #include "amrr.h"
  
@@ -31,22 +24,24 @@ diff -urN madwifi-ng-r2377-20070526.old/ath_rate/amrr/amrr.c madwifi-ng-r2377-20
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-diff -urN madwifi-ng-r2377-20070526.old/ath_rate/minstrel/minstrel.c madwifi-ng-r2377-20070526.dev/ath_rate/minstrel/minstrel.c
---- madwifi-ng-r2377-20070526.old/ath_rate/minstrel/minstrel.c 2007-05-26 18:51:08.653771968 +0200
-+++ madwifi-ng-r2377-20070526.dev/ath_rate/minstrel/minstrel.c 2007-05-26 18:51:09.208687608 +0200
-@@ -116,7 +116,7 @@
+Index: madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath_rate/minstrel/minstrel.c        2007-07-11 22:59:41.620220346 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/minstrel/minstrel.c     2007-07-11 22:59:44.320374218 +0200
+@@ -117,7 +117,7 @@
  
  #include "minstrel.h"
  
--#define       MINSTREL_DEBUG 
-+#undef        MINSTREL_DEBUG 
+-#define       MINSTREL_DEBUG
++#undef        MINSTREL_DEBUG
  #ifdef MINSTREL_DEBUG
  enum {
-       ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-diff -urN madwifi-ng-r2377-20070526.old/ath_rate/onoe/onoe.c madwifi-ng-r2377-20070526.dev/ath_rate/onoe/onoe.c
---- madwifi-ng-r2377-20070526.old/ath_rate/onoe/onoe.c 2007-05-21 19:33:26.000000000 +0200
-+++ madwifi-ng-r2377-20070526.dev/ath_rate/onoe/onoe.c 2007-05-26 18:51:09.209687456 +0200
-@@ -65,7 +65,7 @@
+               ATH_DEBUG_RATE          = 0x00000010    /* rate control */
+Index: madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath_rate/onoe/onoe.c        2007-07-11 22:59:38.312031823 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/onoe/onoe.c     2007-07-11 22:59:44.336375133 +0200
+@@ -66,7 +66,7 @@
  
  #include "onoe.h"
  
@@ -55,10 +50,11 @@ diff -urN madwifi-ng-r2377-20070526.old/ath_rate/onoe/onoe.c madwifi-ng-r2377-20
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-diff -urN madwifi-ng-r2377-20070526.old/ath_rate/sample/sample.c madwifi-ng-r2377-20070526.dev/ath_rate/sample/sample.c
---- madwifi-ng-r2377-20070526.old/ath_rate/sample/sample.c     2007-05-21 19:33:26.000000000 +0200
-+++ madwifi-ng-r2377-20070526.dev/ath_rate/sample/sample.c     2007-05-26 18:51:09.209687456 +0200
-@@ -67,7 +67,7 @@
+Index: madwifi-ng-r2568-20070710/ath_rate/sample/sample.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/ath_rate/sample/sample.c    2007-07-11 22:59:38.320032282 +0200
++++ madwifi-ng-r2568-20070710/ath_rate/sample/sample.c 2007-07-11 22:59:44.352376045 +0200
+@@ -68,7 +68,7 @@
  
  #include "sample.h"
  
@@ -67,43 +63,30 @@ diff -urN madwifi-ng-r2377-20070526.old/ath_rate/sample/sample.c madwifi-ng-r237
  #ifdef SAMPLE_DEBUG
  enum {
        ATH_DEBUG_NODE          = 0x00080000,   /* node management */
-diff -urN madwifi-ng-r2377-20070526.old/net80211/ieee80211_proto.c madwifi-ng-r2377-20070526.dev/net80211/ieee80211_proto.c
---- madwifi-ng-r2377-20070526.old/net80211/ieee80211_proto.c   2007-05-21 17:53:39.000000000 +0200
-+++ madwifi-ng-r2377-20070526.dev/net80211/ieee80211_proto.c   2007-05-26 18:51:09.210687304 +0200
-@@ -312,6 +312,7 @@
+Index: madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_proto.c  2007-07-11 22:59:38.324032509 +0200
++++ madwifi-ng-r2568-20070710/net80211/ieee80211_proto.c       2007-07-11 22:59:44.372377182 +0200
+@@ -286,6 +286,7 @@
  }
- EXPORT_SYMBOL(ieee80211_print_essid);
+ EXPORT_SYMBOL(ieee80211_aclator_get);
  
 +#ifdef IEEE80211_DEBUG
  void
- ieee80211_dump_pkt(struct ieee80211com *ic,
-       const u_int8_t *buf, int len, int rate, int rssi)
-@@ -390,6 +391,7 @@
-       }
+ ieee80211_print_essid(const u_int8_t *essid, int len)
+ {
+@@ -312,7 +313,6 @@
  }
- EXPORT_SYMBOL(ieee80211_dump_pkt);
-+#endif /* IEEE80211_DEBUG */
- int
- ieee80211_fix_rate(struct ieee80211_node *ni, int flags)
-diff -urN madwifi-ng-r2377-20070526.old/net80211/ieee80211_proto.h madwifi-ng-r2377-20070526.dev/net80211/ieee80211_proto.h
---- madwifi-ng-r2377-20070526.old/net80211/ieee80211_proto.h   2007-01-30 05:01:29.000000000 +0100
-+++ madwifi-ng-r2377-20070526.dev/net80211/ieee80211_proto.h   2007-05-26 18:51:09.211687152 +0200
-@@ -247,7 +247,11 @@
- #endif
- int ieee80211_new_state(struct ieee80211vap *, enum ieee80211_state, int);
- void ieee80211_print_essid(const u_int8_t *, int);
-+#ifdef IEEE80211_DEBUG
- void ieee80211_dump_pkt(struct ieee80211com *, const u_int8_t *, int, int, int);
-+#else
-+#define ieee80211_dump_pkt(...)
-+#endif
- struct sk_buff *ieee80211_getcfframe(struct ieee80211vap *, int);
+ EXPORT_SYMBOL(ieee80211_print_essid);
  
- /*
-diff -urN madwifi-ng-r2377-20070526.old/net80211/ieee80211_var.h madwifi-ng-r2377-20070526.dev/net80211/ieee80211_var.h
---- madwifi-ng-r2377-20070526.old/net80211/ieee80211_var.h     2007-05-24 23:26:38.000000000 +0200
-+++ madwifi-ng-r2377-20070526.dev/net80211/ieee80211_var.h     2007-05-26 18:51:09.211687152 +0200
+-#ifdef IEEE80211_DEBUG
+ void
+ ieee80211_dump_pkt(struct ieee80211com *ic,
+       const u_int8_t *buf, int len, int rate, int rssi)
+Index: madwifi-ng-r2568-20070710/net80211/ieee80211_var.h
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/net80211/ieee80211_var.h    2007-07-11 22:59:38.332032964 +0200
++++ madwifi-ng-r2568-20070710/net80211/ieee80211_var.h 2007-07-11 22:59:44.412379463 +0200
 @@ -35,8 +35,8 @@
  #ifndef _NET80211_IEEE80211_VAR_H_
  #define _NET80211_IEEE80211_VAR_H_
@@ -115,9 +98,10 @@ diff -urN madwifi-ng-r2377-20070526.old/net80211/ieee80211_var.h madwifi-ng-r237
  
  /* Definitions for IEEE 802.11 drivers. */
  #include <net80211/ieee80211_linux.h>
-diff -urN madwifi-ng-r2377-20070526.old/tools/do_multi.c madwifi-ng-r2377-20070526.dev/tools/do_multi.c
---- madwifi-ng-r2377-20070526.old/tools/do_multi.c     2007-05-26 18:51:08.203840368 +0200
-+++ madwifi-ng-r2377-20070526.dev/tools/do_multi.c     2007-05-26 18:51:09.212687000 +0200
+Index: madwifi-ng-r2568-20070710/tools/do_multi.c
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/tools/do_multi.c    2007-07-11 22:59:40.348147859 +0200
++++ madwifi-ng-r2568-20070710/tools/do_multi.c 2007-07-11 22:59:44.432380603 +0200
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -139,15 +123,16 @@ diff -urN madwifi-ng-r2377-20070526.old/tools/do_multi.c madwifi-ng-r2377-200705
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-diff -urN madwifi-ng-r2377-20070526.old/tools/Makefile madwifi-ng-r2377-20070526.dev/tools/Makefile
---- madwifi-ng-r2377-20070526.old/tools/Makefile       2007-05-26 18:51:08.203840368 +0200
-+++ madwifi-ng-r2377-20070526.dev/tools/Makefile       2007-05-26 18:51:09.212687000 +0200
+Index: madwifi-ng-r2568-20070710/tools/Makefile
+===================================================================
+--- madwifi-ng-r2568-20070710.orig/tools/Makefile      2007-07-11 22:59:40.388150134 +0200
++++ madwifi-ng-r2568-20070710/tools/Makefile   2007-07-11 22:59:44.448381515 +0200
 @@ -52,7 +52,7 @@
        
  ifdef DOMULTI
  OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
 -      athdebug.o 80211debug.o wlanconfig.o 
-+      wlanconfig.o 
++      wlanconfig.o
  ALL=  ${OBJS} madwifi_multi
  endif