madwifi: reduce the packet loss impact of forced background scans triggered by the...
[openwrt/svn-archive/archive.git] / package / madwifi / patches / 404-linux24_fix.patch
index 237bd6e61aa6552a45fba045d2f5c0cd0ef3fb9e..ecc80f1b92885342b434622546287946467babeb 100644 (file)
@@ -1,13 +1,15 @@
-Index: madwifi-trunk-r3314/ath_hal/Makefile
-===================================================================
---- madwifi-trunk-r3314.orig/ath_hal/Makefile  2008-06-07 01:33:20.180406306 +0200
-+++ madwifi-trunk-r3314/ath_hal/Makefile       2008-06-07 01:33:25.636717245 +0200
-@@ -78,7 +78,7 @@
+--- a/ath_hal/Makefile
++++ b/ath_hal/Makefile
+@@ -78,10 +78,11 @@
  quiet_cmd_uudecode = UUDECODE $@
        cmd_uudecode = $(obj)/uudecode -o $@ $<
  
 -$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
-+$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
  ifdef LINUX24
++$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
        $(Q)$(obj)/uudecode -o $@ $<
  else
++$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
+       $(call if_changed,uudecode)
+ endif