fixes file perms of mountd uci file and init.d script, thx yann.lopez
[openwrt/svn-archive/archive.git] / package / mountd / Makefile
index 5463384a0af82354b90e889a688c650393712bb3..ded7d30d182f9988f29b55e376dbfdb5aa0d755f 100644 (file)
@@ -17,7 +17,7 @@ define Package/mountd
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=OpenWrt automount daemon
-  DEPENDS:=@USB_SUPPORT +uci +kmod-usb-storage +kmod-fs-autofs4
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +uci +kmod-usb-storage +kmod-fs-autofs4
   URL:=http://www.openwrt.org
 endef
 
@@ -35,8 +35,8 @@ endef
 define Package/mountd/install
        $(INSTALL_DIR) $(1)/sbin/ $(1)/etc/config/ $(1)/etc/init.d/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/mountd $(1)/sbin/
-       $(INSTALL_BIN) ./files/mountd.config $(1)/etc/config/mountd
-       $(INSTALL_DATA) ./files/mountd.init $(1)/etc/init.d/mountd
+       $(INSTALL_DATA) ./files/mountd.config $(1)/etc/config/mountd
+       $(INSTALL_BIN) ./files/mountd.init $(1)/etc/init.d/mountd
 endef
 
 $(eval $(call BuildPackage,mountd))