package/mtd: fix automatic partition size detection in fis_remap
[openwrt/svn-archive/archive.git] / package / mtd / Makefile
index 3561a9b397e1a204cffccae7cbb278d2510391e7..9438b96fdc2487468f779d1cddcbfad40c1cb3e4 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,9 +9,10 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mtd
-PKG_RELEASE:=8
+PKG_RELEASE:=12
 
 PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
+STAMP_PREPARED := $(STAMP_PREPARED)_$(call confvar,CONFIG_MTD_REDBOOT_PARTS)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,12 +34,13 @@ endef
 
 target=$(firstword $(subst -, ,$(BOARD)))
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               TARGET=$(target) \
-               CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(target)=1 -Wall"
-endef
+MAKE_FLAGS += TARGET="$(target)"
+TARGET_CFLAGS += -Dtarget_$(target)=1 -Wall
+
+ifdef CONFIG_MTD_REDBOOT_PARTS
+  MAKE_FLAGS += FIS_SUPPORT=1
+  TARGET_CFLAGS += -DFIS_SUPPORT=1
+endif
 
 define Package/mtd/install
        $(INSTALL_DIR) $(1)/sbin