firewall3: update to git head
[openwrt/svn-archive/archive.git] / package / network / config / firewall3 / Makefile
index aecf09327d59af664b284bf59198ec897f4c47ef..1ec8ae651daab3e4fd63000be7095122f92da692 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall3
-PKG_VERSION:=2013-05-21.1
+PKG_VERSION:=2013-05-23
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/firewall3.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=a7d923052fa3ca69a5f5453a872bc976fbb0f75a
+PKG_SOURCE_VERSION:=a93d95470803e9026c725fc7081ac8a06191ea6a
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
@@ -47,7 +47,7 @@ define Build/Compile
 endef
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_LDFLAGS += -Wl,--gc-sections -Wl,--whole-archive
 
 define Package/firewall3/install
        $(INSTALL_DIR) $(1)/sbin