hostapd: remove old button hotplug script
[openwrt/svn-archive/archive.git] / package / network / services / hostapd / Makefile
index 485a8fad0cd1a9bab8c9d73fc119ed788db63c9b..1c49451fa471f4d13487b91087c9b75bbabed8c9 100644 (file)
@@ -303,14 +303,9 @@ Package/hostapd-mini/install = $(Package/hostapd/install)
 
 ifneq ($(LOCAL_TYPE),supplicant)
   define Package/hostapd-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/hotplug.d/button
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/rc.button
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
-       $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
-       $(if $(CONFIG_PROCD_INIT),
-               $(INSTALL_DIR) $(1)/etc/rc.button/
-               $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps,
-               $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
-       )
+       $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps,
   endef
 endif