iputils: add missing includes, fix musl support
[openwrt/svn-archive/archive.git] / package / network / utils / iputils / Makefile
index eeb6deb900c5845cfeb483989365d042c434fb6f..19061ca77ac574d2cf0322f119f83b9e6619e502 100644 (file)
@@ -121,10 +121,14 @@ define Package/iputils-traceroute6/description
   Traces path to a network host (IPv6).
 endef
 
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -D__UCLIBC__
+endif
+
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)" \
        CONFIG_IPV6="$(CONFIG_IPV6)" \
-       CONFIG_USE_UCLIBC="$(CONFIG_USE_UCLIBC)" \
+       CONFIG_USE_UCLIBC="$(CONFIG_USE_UCLIBC)$(CONFIG_USE_MUSL)" \
 
 define Package/iputils-arping/install
        $(INSTALL_DIR) $(1)/usr/bin