cleanup ntfs-3g makefile (remove kernel.mk include, unused configure options...)
[openwrt/svn-archive/archive.git] / package / ntfs-3g / Makefile
index 7fc208556ad59f72c7c08578c26d98264c45f58a..686c0e3c9541b2bd07aaa28bde13deef25b0b9cc 100644 (file)
@@ -7,7 +7,6 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ntfs-3g
 PKG_VERSION:=1.0
@@ -16,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.ntfs-3g.org/
 PKG_MD5SUM:=873a8de662849d129fc7c475ad3f5447
-PKG_CAT:=zcat
 
 PKG_BUILD_DEPENDS:=libfuse
 
@@ -32,51 +30,9 @@ define Package/ntfs-3g
   URL:=http://www.ntfs-3g.org
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               touch configure.in ; \
-               touch aclocal.m4 ; \
-               touch Makefile.in ; \
-               touch include/config.h.in ; \
-               touch configure ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --enable-kernel-module \
-                       --enable-lib \
-                       --enable-util \
-                       --disable-example \
-                       --disable-auto-modprobe \
-                       --with-kernel="$(LINUX_DIR)" \
-                       --disable-mtab \
-       );
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -106,3 +62,6 @@ define Package/ntfs-3g/install
 endef
 
 $(eval $(call BuildPackage,ntfs-3g))
+$(eval $(call RequireCommand,pkg-config, \
+       $(PKG_NAME) requires pkg-config. \
+))