[package] nvvram: no checksum error recording on WRT54G3GV2(-VF)
[openwrt/svn-archive/archive.git] / package / nvram / Makefile
index c2270714fdd301d1d359d577bdaec9316f30220e..5ff3791c5ee69c048765fb55c6131fe962959113 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2009-2010 Jo-Philipp Wich <xm@subsignal.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nvram
-PKG_RELEASE:=5
+PKG_RELEASE:=9
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -18,12 +18,12 @@ define Package/nvram
   SECTION:=utils
   CATEGORY:=Base system
   TITLE:=Userspace port of the Broadcom NVRAM manipulation tool
-  DEPENDS:=@TARGET_brcm_2_4||@TARGET_brcm47xx
+  DEPENDS:=@TARGET_brcm47xx||@TARGET_ar71xx
 endef
 
 define Package/nvram/description
  This package contains an utility to manipulate NVRAM on Broadcom based devices.
- It works on both brcm-2.4 and bcm47xx (Linux 2.6) without using the kernel api.
+ It works on bcm47xx (Linux 2.6) without using the kernel api.
 endef
 
 define Build/Prepare
@@ -41,6 +41,12 @@ define Build/Compile
                LDFLAGS="$(TARGET_LDFLAGS)"
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/libnvram.so.0.1 $(1)/usr/lib/
+       ln -s libnvram.so.0.1 $(1)/usr/lib/libnvram.so
+endef
+
 define Package/nvram/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram