[package] openssl: add a patch to support DTLS compatibility with Cisco AnyConnect...
[openwrt/svn-archive/archive.git] / package / openssl / Makefile
index 0bd07655b24910545821a95c369db22df5bc89fe..11a9ef2e28c5f65727df66e6e50562cbf3c93dca 100644 (file)
@@ -1,23 +1,24 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.8i
-PKG_RELEASE:=1
+PKG_VERSION:=0.9.8k
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=561e00f18821c74b2b86c8c7786f9d8b
+PKG_MD5SUM:=e555c6d58d276aec7fdc53363e338ab3
+
+PKG_BUILD_DEPENDS:=ocf-crypto-headers
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,9 +28,9 @@ define Package/openssl/Default
 endef
 
 define Package/openssl/Default/description
- The OpenSSL Project is a collaborative effort to develop a robust, 
- commercial-grade, full-featured, and Open Source toolkit implementing the 
- Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) 
+ The OpenSSL Project is a collaborative effort to develop a robust,
+ commercial-grade, full-featured, and Open Source toolkit implementing the
+ Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  protocols as well as a full-strength general purpose cryptography library.
 endef
 
@@ -43,7 +44,7 @@ endef
 
 define Package/libopenssl/description
 $(call Package/openssl/Default/description)
- This package contains the OpenSSL shared libraries, needed by other 
+ This package contains the OpenSSL shared libraries, needed by other
  programs.
 endef
 
@@ -68,10 +69,10 @@ endef
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
                                        no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
 ifeq ($(BOARD),ixp4xx)
-OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
                                        no-sse2 no-perlasm --with-cryptodev
 else
-OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
                                        no-engines no-sse2 no-perlasm
 endif