[package] openssl: add a patch to support DTLS compatibility with Cisco AnyConnect...
[openwrt/svn-archive/archive.git] / package / openssl / Makefile
index 6464b9d0c836ae725a26c8303b6cabd08c95483a..11a9ef2e28c5f65727df66e6e50562cbf3c93dca 100644 (file)
@@ -1,15 +1,14 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.8e
+PKG_VERSION:=0.9.8k
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -17,30 +16,36 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=3a7ff24f6ea5cd711984722ad654b927
+PKG_MD5SUM:=e555c6d58d276aec7fdc53363e338ab3
+
+PKG_BUILD_DEPENDS:=ocf-crypto-headers
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/openssl/Default
   TITLE:=Open source SSL toolkit
-  DESCRIPTION:=\
-       The OpenSSL Project is a collaborative effort to develop a robust, \\\
-       commercial-grade, full-featured, and Open Source toolkit implementing the \\\
-       Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) \\\
-       protocols as well as a full-strength general purpose cryptography library.
   URL:=http://www.openssl.org/
 endef
 
+define Package/openssl/Default/description
+ The OpenSSL Project is a collaborative effort to develop a robust,
+ commercial-grade, full-featured, and Open Source toolkit implementing the
+ Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
+ protocols as well as a full-strength general purpose cryptography library.
+endef
+
 define Package/libopenssl
-  $(call Package/openssl/Default)
+$(call Package/openssl/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE+= (libraries)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the OpenSSL shared libraries, needed by other \\\
-       programs.
+endef
+
+define Package/libopenssl/description
+$(call Package/openssl/Default/description)
+ This package contains the OpenSSL shared libraries, needed by other
+ programs.
 endef
 
 define Package/openssl-util
@@ -49,19 +54,27 @@ define Package/openssl-util
   CATEGORY:=Utilities
   DEPENDS:=+libopenssl
   TITLE+= (utility)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the OpenSSL command-line utility.
 endef
 
 define Package/openssl-util/conffiles
 /etc/ssl/openssl.cnf
 endef
 
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
+define Package/openssl-util/description
+$(call Package/openssl/Default/description)
+ This package contains the OpenSSL command-line utility.
+endef
+
+
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
                                        no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
-OPENSSL_OPTIONS:= shared no-dso no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+ifeq ($(BOARD),ixp4xx)
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
+                                       no-sse2 no-perlasm --with-cryptodev
+else
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic \
                                        no-engines no-sse2 no-perlasm
+endif
 
 
 define Build/Configure
@@ -69,14 +82,16 @@ define Build/Configure
                ./Configure linux-openwrt \
                        --prefix=/usr \
                        --openssldir=/etc/ssl \
-                       -I$(STAGING_DIR)/usr/include \
-                       -L$(STAGING_DIR)/usr/lib -ldl \
+                       $(TARGET_CPPFLAGS) \
+                       $(TARGET_LDFLAGS) -ldl \
                        -DOPENSSL_SMALL_FOOTPRINT \
                        $(OPENSSL_NO_CIPHERS) \
                        $(OPENSSL_OPTIONS) \
        )
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
@@ -102,15 +117,13 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/openssl \
-               $(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*}
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(1)/usr/include/
+       mkdir -p $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
+       $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
 endef
 
 define Package/libopenssl/install
@@ -126,7 +139,7 @@ define Package/openssl-util/install
        $(INSTALL_DIR) $(1)/etc/ssl/private
        chmod 0700 $(1)/etc/ssl/private
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libopenssl))