add $(STAGING_DIR) as argument to the InstallDev template and update packages accordi...
[openwrt/svn-archive/archive.git] / package / openssl / Makefile
index 015404d90b827388ee67ab2e2af2a423c0475e53..270fe5e755cd4b8fa4b6e807bee796b2a5f16705 100644 (file)
@@ -23,24 +23,28 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/openssl/Default
   TITLE:=Open source SSL toolkit
-  DESCRIPTION:=\
-       The OpenSSL Project is a collaborative effort to develop a robust, \\\
-       commercial-grade, full-featured, and Open Source toolkit implementing the \\\
-       Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) \\\
-       protocols as well as a full-strength general purpose cryptography library.
   URL:=http://www.openssl.org/
 endef
 
+define Package/openssl/Default/description
+ The OpenSSL Project is a collaborative effort to develop a robust, 
+ commercial-grade, full-featured, and Open Source toolkit implementing the 
+ Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) 
+ protocols as well as a full-strength general purpose cryptography library.
+endef
+
 define Package/libopenssl
-  $(call Package/openssl/Default)
+$(call Package/openssl/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE+= (libraries)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the OpenSSL shared libraries, needed by other \\\
-       programs.
+endef
+
+define Package/libopenssl/description
+$(call Package/openssl/Default/description)
+ This package contains the OpenSSL shared libraries, needed by other 
+ programs.
 endef
 
 define Package/openssl-util
@@ -49,15 +53,18 @@ define Package/openssl-util
   CATEGORY:=Utilities
   DEPENDS:=+libopenssl
   TITLE+= (utility)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the OpenSSL command-line utility.
 endef
 
 define Package/openssl-util/conffiles
 /etc/ssl/openssl.cnf
 endef
 
+define Package/openssl-util/description
+$(call Package/openssl/Default/description)
+ This package contains the OpenSSL command-line utility.
+endef
+
+
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
                                        no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
 OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
@@ -102,15 +109,21 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(STAGING_DIR)/usr/lib/
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(1)/usr/include/
+       mkdir -p $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
+       $(SED) 's,^includedir=.*,includedir=$(1)/usr/include,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+       $(SED) 's,^libdir=.*,libdir=$(1)/usr/lib,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+       $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
 endef
 
 define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/openssl \
-               $(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*}
+       rm -rf  $(1)/usr/include/openssl \
+               $(1)/usr/lib/lib{crypto,ssl}.{a,so*} \
+               $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
 endef
 
 define Package/libopenssl/install