fix for ticket:989
[openwrt/svn-archive/archive.git] / package / openssl / Makefile
index 7bb31c8cb311c9d7b8babc3e6db1ed3d7f7bf989..9c1f6bf7f8078a99ce7ef7464b3db192b09b6f38 100644 (file)
@@ -62,8 +62,11 @@ define Package/openssl-util/conffiles
 /etc/ssl/openssl.cnf
 endef
 
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-rmd160 no-aes192
-OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-krb5 no-threads zlib-dynamic no-engines
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
+                                       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+OPENSSL_OPTIONS:= shared no-dso no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+                                       no-engines no-sse2 no-perlasm
+
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
@@ -115,18 +118,18 @@ define Build/UninstallDev
 endef
 
 define Package/libopenssl/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(1)/usr/lib/
        chmod 0644 $(1)/usr/lib/*
 endef
 
 define Package/openssl-util/install
-       install -d -m0755 $(1)/etc/ssl
+       $(INSTALL_DIR) $(1)/etc/ssl
        $(CP) $(PKG_INSTALL_DIR)/etc/ssl/openssl.cnf $(1)/etc/ssl/
-       install -d -m0755 $(1)/etc/ssl/certs
-       install -d -m0755 $(1)/etc/ssl/private
+       $(INSTALL_DIR) $(1)/etc/ssl/certs
+       $(INSTALL_DIR) $(1)/etc/ssl/private
        chmod 0700 $(1)/etc/ssl/private
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
 endef