enable dso support back in openssl, needed to use shared zlib compression, and should...
[openwrt/svn-archive/archive.git] / package / openssl / Makefile
index 54b4aac0897e6e33a27eb28fed2abc08ec591ad2..b097c1b37f5e32fa45192481a8bf1b3b37709d22 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_VERSION:=0.9.8d
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
@@ -18,10 +18,6 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
 PKG_MD5SUM:=8ed1853538e1d05a1f5ada61ebf8bffa
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -62,8 +58,11 @@ define Package/openssl-util/conffiles
 /etc/ssl/openssl.cnf
 endef
 
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-rmd160 no-aes192
-OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-krb5 no-threads zlib-dynamic no-engines
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
+                                       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+                                       no-engines no-sse2 no-perlasm
+
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
@@ -81,11 +80,11 @@ endef
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) -j1 \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                MAKEDEPPROG="$(TARGET_CROSS)gcc" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
                depend
-       $(MAKE) -C $(PKG_BUILD_DIR) -j1 \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
@@ -93,11 +92,11 @@ define Build/Compile
                all build-shared
        # Work around openssl build bug to link libssl.so with libcrypto.so.
        -rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
-       $(MAKE) -C $(PKG_BUILD_DIR) -j1 \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
                do_linux-shared
-       $(MAKE) -C $(PKG_BUILD_DIR) -j1 \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
                install
 endef
@@ -115,18 +114,18 @@ define Build/UninstallDev
 endef
 
 define Package/libopenssl/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(1)/usr/lib/
        chmod 0644 $(1)/usr/lib/*
 endef
 
 define Package/openssl-util/install
-       install -d -m0755 $(1)/etc/ssl
+       $(INSTALL_DIR) $(1)/etc/ssl
        $(CP) $(PKG_INSTALL_DIR)/etc/ssl/openssl.cnf $(1)/etc/ssl/
-       install -d -m0755 $(1)/etc/ssl/certs
-       install -d -m0755 $(1)/etc/ssl/private
+       $(INSTALL_DIR) $(1)/etc/ssl/certs
+       $(INSTALL_DIR) $(1)/etc/ssl/private
        chmod 0700 $(1)/etc/ssl/private
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
 endef