firmware-utils: move bcm_tag.h here
[openwrt/svn-archive/archive.git] / package / openssl / Makefile
index 9c1f6bf7f8078a99ce7ef7464b3db192b09b6f38..cfc3b3d92d26fc2b78c5db125eae0c4d383922d6 100644 (file)
@@ -1,15 +1,14 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.8d
+PKG_VERSION:=1.0.1c
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -17,34 +16,42 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=8ed1853538e1d05a1f5ada61ebf8bffa
-PKG_CAT:=zcat
+PKG_MD5SUM:=ae412727c8c15b67880aef7bd2999b2e
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=ocf-crypto-headers
+PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE_CRYPTO CONFIG_OPENSSL_ENGINE_DIGEST
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/openssl/Default
   TITLE:=Open source SSL toolkit
-  DESCRIPTION:=\
-       The OpenSSL Project is a collaborative effort to develop a robust, \\\
-       commercial-grade, full-featured, and Open Source toolkit implementing the \\\
-       Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) \\\
-       protocols as well as a full-strength general purpose cryptography library.
   URL:=http://www.openssl.org/
 endef
 
+define Package/libopenssl/config
+source "$(SOURCE)/Config.in"
+endef
+
+define Package/openssl/Default/description
+The OpenSSL Project is a collaborative effort to develop a robust,
+commercial-grade, full-featured, and Open Source toolkit implementing the Secure
+Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) protocols as well
+as a full-strength general purpose cryptography library.
+endef
+
 define Package/libopenssl
-  $(call Package/openssl/Default)
+$(call Package/openssl/Default)
   SECTION:=libs
+  SUBMENU:=SSL
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE+= (libraries)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the OpenSSL shared libraries, needed by other \\\
-       programs.
+  MENU:=1
+endef
+
+define Package/libopenssl/description
+$(call Package/openssl/Default/description)
+This package contains the OpenSSL shared libraries, needed by other programs.
 endef
 
 define Package/openssl-util
@@ -53,74 +60,109 @@ define Package/openssl-util
   CATEGORY:=Utilities
   DEPENDS:=+libopenssl
   TITLE+= (utility)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the OpenSSL command-line utility.
 endef
 
 define Package/openssl-util/conffiles
 /etc/ssl/openssl.cnf
 endef
 
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
-                                       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
-OPENSSL_OPTIONS:= shared no-dso no-ec no-err no-fips no-hw no-threads zlib-dynamic \
-                                       no-engines no-sse2 no-perlasm
+define Package/openssl-util/description
+$(call Package/openssl/Default/description)
+This package contains the OpenSSL command-line utility.
+endef
+
 
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
+       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic no-sse2
+
+ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
+  OPENSSL_OPTIONS += -DHAVE_CRYPTODEV
+  ifdef CONFIG_OPENSSL_ENGINE_DIGEST
+    OPENSSL_OPTIONS += -DUSE_CRYPTODEV_DIGESTS
+  endif
+else
+  OPENSSL_OPTIONS += no-engines
+endif
+
+ifeq ($(CONFIG_x86_64),y)
+  OPENSSL_TARGET:=linux-x86_64
+else
+  OPENSSL_OPTIONS+=no-sse2
+  ifeq ($(CONFIG_mips)$(CONFIG_mipsel),y)
+    OPENSSL_TARGET:=linux-mips-openwrt
+  else
+    OPENSSL_TARGET:=linux-generic-openwrt
+    OPENSSL_OPTIONS+=no-perlasm
+  endif
+endif
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               ./Configure linux-openwrt \
+               ./Configure $(OPENSSL_TARGET) \
                        --prefix=/usr \
                        --openssldir=/etc/ssl \
-                       -I$(STAGING_DIR)/usr/include \
-                       -L$(STAGING_DIR)/usr/lib -ldl \
+                       $(TARGET_CPPFLAGS) \
+                       $(TARGET_LDFLAGS) -ldl \
                        -DOPENSSL_SMALL_FOOTPRINT \
                        $(OPENSSL_NO_CIPHERS) \
                        $(OPENSSL_OPTIONS) \
        )
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
+       # XXX: OpenSSL "make depend" will look for installed headers before its own,
+       # so remove installed stuff first
+       -$(SUBMAKE) -j1 clean-staging
        $(MAKE) -C $(PKG_BUILD_DIR) \
                MAKEDEPPROG="$(TARGET_CROSS)gcc" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
                depend
+       $(_SINGLE)$(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               AR="$(TARGET_CROSS)ar r" \
+               RANLIB="$(TARGET_CROSS)ranlib" \
+               OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
+               all
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
-               all build-shared
+               $(OPENSSL_MAKEFLAGS) \
+               build-shared
        # Work around openssl build bug to link libssl.so with libcrypto.so.
        -rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
                do_linux-shared
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+               $(OPENSSL_MAKEFLAGS) \
                install
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/openssl \
-               $(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*}
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
+       [ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc || true
 endef
 
 define Package/libopenssl/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(1)/usr/lib/
-       chmod 0644 $(1)/usr/lib/*
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libcrypto.so.* $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libssl.so.* $(1)/usr/lib/
 endef
 
 define Package/openssl-util/install
@@ -130,7 +172,7 @@ define Package/openssl-util/install
        $(INSTALL_DIR) $(1)/etc/ssl/private
        chmod 0700 $(1)/etc/ssl/private
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libopenssl))