firmware-utils: move bcm_tag.h here
[openwrt/svn-archive/archive.git] / package / openssl / Makefile
index ef0edb0daf2ff7bf1a8d9216c15d45a9e2984925..cfc3b3d92d26fc2b78c5db125eae0c4d383922d6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.8m
+PKG_VERSION:=1.0.1c
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -16,10 +16,10 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=898bf125370926d5f692a2201124f8ec
+PKG_MD5SUM:=ae412727c8c15b67880aef7bd2999b2e
 
-PKG_BUILD_DEPENDS := ocf-crypto-headers
-PKG_CONFIG_DEPENDS := CONFIG_OPENSSL_ENGINE
+PKG_BUILD_DEPENDS:=ocf-crypto-headers
+PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE_CRYPTO CONFIG_OPENSSL_ENGINE_DIGEST
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,10 +33,10 @@ source "$(SOURCE)/Config.in"
 endef
 
 define Package/openssl/Default/description
- The OpenSSL Project is a collaborative effort to develop a robust,
- commercial-grade, full-featured, and Open Source toolkit implementing the
- Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
- protocols as well as a full-strength general purpose cryptography library.
+The OpenSSL Project is a collaborative effort to develop a robust,
+commercial-grade, full-featured, and Open Source toolkit implementing the Secure
+Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) protocols as well
+as a full-strength general purpose cryptography library.
 endef
 
 define Package/libopenssl
@@ -46,12 +46,12 @@ $(call Package/openssl/Default)
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE+= (libraries)
+  MENU:=1
 endef
 
 define Package/libopenssl/description
 $(call Package/openssl/Default/description)
- This package contains the OpenSSL shared libraries, needed by other
- programs.
+This package contains the OpenSSL shared libraries, needed by other programs.
 endef
 
 define Package/openssl-util
@@ -68,25 +68,38 @@ endef
 
 define Package/openssl-util/description
 $(call Package/openssl/Default/description)
- This package contains the OpenSSL command-line utility.
+This package contains the OpenSSL command-line utility.
 endef
 
 
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
-                                       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
 OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic no-sse2
 
-ifdef CONFIG_OPENSSL_ENGINE
-  OPENSSL_OPTIONS += --with-cryptodev
+ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
+  OPENSSL_OPTIONS += -DHAVE_CRYPTODEV
+  ifdef CONFIG_OPENSSL_ENGINE_DIGEST
+    OPENSSL_OPTIONS += -DUSE_CRYPTODEV_DIGESTS
+  endif
 else
   OPENSSL_OPTIONS += no-engines
 endif
 
-OPENSSL_OPTIONS += no-perlasm
+ifeq ($(CONFIG_x86_64),y)
+  OPENSSL_TARGET:=linux-x86_64
+else
+  OPENSSL_OPTIONS+=no-sse2
+  ifeq ($(CONFIG_mips)$(CONFIG_mipsel),y)
+    OPENSSL_TARGET:=linux-mips-openwrt
+  else
+    OPENSSL_TARGET:=linux-generic-openwrt
+    OPENSSL_OPTIONS+=no-perlasm
+  endif
+endif
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               ./Configure linux-openwrt \
+               ./Configure $(OPENSSL_TARGET) \
                        --prefix=/usr \
                        --openssldir=/etc/ssl \
                        $(TARGET_CPPFLAGS) \
@@ -108,13 +121,20 @@ define Build/Compile
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
                $(OPENSSL_MAKEFLAGS) \
                depend
+       $(_SINGLE)$(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               AR="$(TARGET_CROSS)ar r" \
+               RANLIB="$(TARGET_CROSS)ranlib" \
+               OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
+               all
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
                $(OPENSSL_MAKEFLAGS) \
-               all build-shared
+               build-shared
        # Work around openssl build bug to link libssl.so with libcrypto.so.
        -rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -123,19 +143,20 @@ define Build/Compile
                $(OPENSSL_MAKEFLAGS) \
                do_linux-shared
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
                $(OPENSSL_MAKEFLAGS) \
                install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(1)/usr/include/
-       mkdir -p $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+       [ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc || true
 endef
 
 define Package/libopenssl/install