[openssl] revert threadsafe patch
[openwrt/svn-archive/archive.git] / package / openssl / Makefile
index 424bd396250b08bb34d981cfcd437b32187bb3ca..d95783aac95d88927e97ac2fae7a331d857c9750 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=1.0.1
+PKG_VERSION:=1.0.1c
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -16,10 +16,10 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=134f168bc2a8333f19f81d684841710b
+PKG_MD5SUM:=ae412727c8c15b67880aef7bd2999b2e
 
 PKG_BUILD_DEPENDS:=ocf-crypto-headers
-PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE
+PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE_CRYPTO CONFIG_OPENSSL_ENGINE_DIGEST
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -73,20 +73,28 @@ endef
 
 
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
-                                       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+       no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
 OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic no-sse2
 
-ifdef CONFIG_OPENSSL_ENGINE
+ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
   OPENSSL_OPTIONS += -DHAVE_CRYPTODEV
+  ifdef CONFIG_OPENSSL_ENGINE_DIGEST
+    OPENSSL_OPTIONS += -DUSE_CRYPTODEV_DIGESTS
+  endif
 else
   OPENSSL_OPTIONS += no-engines
 endif
 
-OPENSSL_OPTIONS += no-perlasm
+ifeq ($(CONFIG_x86_64),y)
+  OPENSSL_TARGET:=linux-x86_64
+else
+  OPENSSL_TARGET:=linux-openwrt
+  OPENSSL_OPTIONS+=no-perlasm no-sse2
+endif
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               ./Configure linux-openwrt \
+               ./Configure $(OPENSSL_TARGET) \
                        --prefix=/usr \
                        --openssldir=/etc/ssl \
                        $(TARGET_CPPFLAGS) \