opkg: use -ffunction-sections, -fdata-sections and --gc-sections
[openwrt/svn-archive/archive.git] / package / opkg / Makefile
index 4d702bae9cfbe007cd3bb9b36c85ae7bfaa6d5ec..0b07d5b49965d2957be55ba045f57704b465e8c7 100644 (file)
@@ -46,6 +46,7 @@ define Package/opkg/conffiles
 endef
 
 TARGET_CFLAGS += $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
 EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 
 CONFIGURE_ARGS += \
@@ -59,6 +60,7 @@ define Build/Compile
                CC="$(TARGET_CC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                HOST_CPU="$(PKGARCH)" \
+               LDFLAGS="-Wl,--gc-sections" \
                all install
 endef
 
@@ -77,8 +79,6 @@ define Build/InstallDev
 endef
 
 
-HOST_BUILD_DEPENDS:=libtool/host
-
 HOST_CONFIGURE_ARGS+= \
        --disable-curl \
        --disable-gpg \